Search found 248 matches

Search found 248 matches

Re: How to change the sort order of products in the cart (OpenCart 3.0.2.0)?

thekrotek,

Yeah, I found the code with the query to fetch the bestsellers. I modified it to only include products ordered in the last 120 days.

Thanks again for all the help!

Larry

Jump to post
  • Fri Oct 11, 2019 4:45 am
  • Replies 5
  • Views 269
Re: How to change the sort order of products in the cart (OpenCart 3.0.2.0)?

thekrotek, Since you have been so helpful here, (and many times in the past), could I ask you a quick question? Do you know what determines which products are in the "Bestsellers" list ... Is it the products that have sold the most quantity, or is it based on total dollar amount sold for each produc...

Jump to post
  • Fri Oct 11, 2019 1:05 am
  • Replies 5
  • Views 269
Re: How to change the sort order of products in the cart (OpenCart 3.0.2.0)?

thekrotek, that seems to have solved the issue.

I was trying to add changes to /store/catalog/controller/checkout/cart.php, and not the cart.php in /store/system/library/cart.

Cannot thank you enough!

Jump to post
  • Fri Oct 11, 2019 12:55 am
  • Replies 5
  • Views 269
How to change the sort order of products in the cart (OpenCart 3.0.2.0)?

Hello, By default, products in the cart seem to be sorted by date added (The date_added field in the product table). I need the products in the cart to be sorted by model (the model field in the product table). For the life of me, I cannot find the code that is setting the default to "date_added". I...

Jump to post
  • Thu Oct 10, 2019 6:40 am
  • Replies 5
  • Views 269
Re: sorting products by model

I need to do something similar. When there are products in the cart, I need them to be sorted by model, not by date_added, as they are now. Where would I change this in the code? For the life of me, I cannot find it.

Thanks in advance!

Jump to post
  • Thu Oct 10, 2019 5:18 am
  • Replies 7
  • Views 503
Re: PHP Error Message

I finally figured out the problem with the image uploading feature. While doing some digging on the hosting server, I noticed that OpenCart was set to automatically upgrade when new version came out. Because of this the theme was no longer compatible with OpenCart. The current version is 3.0.3.1, h...

Jump to post
  • Thu Mar 07, 2019 1:04 am
  • Replies 15
  • Views 1042
Re: Which database table holds the default group indicator? (OpenCart 3.0.2.0)

Sorry to hear that you have 5 days spent for nothing. But if you migrate/convert the database manuel, you will need not more than 3 hours maximum. No need to write sophisticated scripts. It took me less than half a day to make a spreadsheet showing each field of each table, for version 1.4.9.3 comp...

Jump to post
  • Tue Feb 19, 2019 3:18 pm
  • Replies 4
  • Views 309
Re: Suggestions on Upgrading site from v1.4.9.3 to v3.x

Thank you to all that replied. I just TODAY (February 18, 2019) got email notification that you all had replied to my original request back on Dec 18 of LAST YEAR. Don't know what the issue is with the OpenCart forum, but I posted in a different post that I was not receiving email notices from the f...

Jump to post
  • Tue Feb 19, 2019 10:52 am
  • Replies 5
  • Views 645
Re: Which database table holds the default group indicator? (OpenCart 3.0.2.0)

Hello, what I will never understand is, that a developer asks such easy questions?! You are writing such important scripts, and do not know what you are doing? You should be able to read the database before such. But, try setting table and config_customer_group_id OSWorX, maybe because I have spent...

Jump to post
  • Tue Feb 19, 2019 10:36 am
  • Replies 4
  • Views 309
Re: Why is PayPal Guest Checkout suddenly requiring selection of a Shipping Method (PayPal Payments Standard)

Turns out that this problem was caused by having shipping tables in OpenCart AND in PayPal. I removed the shipping tables in PayPal, and the problem went away. Don't know why the problem just suddenly appeared, because the shipping options had been in PayPal for a long time. But at least it is now f...

Jump to post
  • Tue Feb 19, 2019 1:45 am
  • Replies 3
  • Views 486
Re: OpenCart 2.3.0.2 PayPal Standard not passing Shipping Address to PayPal

The PayPal docs are here. Although they are a bit confusing as some list the zone names and not codes. https://developer.paypal.com/docs/classic/api/state_codes/ Going by the PayPal Express module it look like Brazil, Canada, Italy, Mexico and USA are the main ones. But don't use the database ids, ...

Jump to post
  • Mon Jan 28, 2019 6:10 pm
  • Replies 22
  • Views 7597
Why is PayPal Guest Checkout suddenly requiring selection of a Shipping Method (PayPal Payments Standard)

Hello all, Just upgraded a 1.4.9.3 store to 3.0.2.0. 1. Customer selects Store Pickup as the shipping method, and checks out. 2. Customer is taken to PayPal, where they select the option to "Pay with Debit or Credit Card", and is routed to the PayPal Guest Checkout screen. 3. PayPal Guest Checkout d...

Jump to post
  • Fri Jan 25, 2019 5:23 pm
  • Replies 3
  • Views 486
Re: OpenCart 2.3.0.2 (and 3.0.2.0) PayPal Standard not passing Shipping Address to PayPal

Have you made the changes in catalog/controller/extension/payment/pp_standard.php? The issue could also be that the state is missing. Try adding something like the following after $data['country'] = $order_info['payment_iso_code_2'];. if ($order_info['payment_iso_code_2'] == 'US') { $data['state'] ...

Jump to post
  • Thu Jan 24, 2019 6:27 am
  • Replies 22
  • Views 7597
Re: OpenCart 2.3.0.2 PayPal Standard not passing Shipping Address to PayPal

If anyone is looking to fix this issue in 3.0.x.x, it seems to be here: catalog/view/theme/default/template/extension/payment/pp_standard.twig Lido, I added the state to the pp_standard.twig file (OpenCart 3.0.2.0), but the state is still not being passed to paypal standard. I also changed the valu...

Jump to post
  • Thu Jan 24, 2019 2:58 am
  • Replies 22
  • Views 7597
3.0.3.1 Error related to Google Shopping Advertising module when copying product

Hello all, I don't know if this bug has been fixed after 3.0.3.1 (I didn't see it mentioned anywhere in the forum), so I am posting about it here. Curious to know if anyone else can replicate this error. It doesn't occur in 3.0.2.0. Go to Catalog > Products, then select a product (checkbox), then cl...

Jump to post
  • Thu Jan 10, 2019 2:37 pm
  • Replies 72
  • Views 23301
Re: Google Smart Shopping feature - pilot testers wanted!

I am planning on providing feedback on the Google form mentioned in the original post, but I wanted to mention this here, so forum visitors could see it. I don't know if this bug has been fixed, but in version 3.0.3.1, if you go to Catalog > Products, then select a product (checkbox), then click the...

Jump to post
  • Thu Jan 10, 2019 2:20 pm
  • Replies 8
  • Views 2676
Question about upgrading to OpenCart 3.0.3.0 after a 3rd party theme has been installed

Hello all,

I recently installed 3.0.2.0, then overlaid it with a 3rd party theme. Everything is working great.

My question is, will I be ok if I upgrade OpenCart to 3.0.3.0, or is that likely to break things?

Thanks in advance!

Jump to post
  • Sun Jan 06, 2019 12:54 pm
  • Replies 3
  • Views 284
Re: Your shopping cart is empty!

Bravo vladborozna,

I always hate to modify core files, but your solution appears to have fixed this issue on all empty pages!

Thank you!

Jump to post
  • Sun Jan 06, 2019 12:26 pm
  • Replies 15
  • Views 2960
Re: Opencart 3.0.2.0 default theme doesn't show changes

Ok, I've read everything I can find on this problem where twig file changes are not saved. 1. I've done all my editing in the Admin panel's Theme Editor. 2. I've cleared my theme cache and module cache each time after making and saving my changes to the twig files. 3. Re-enter the Admin panel's Them...

Jump to post
  • Tue Jan 01, 2019 5:28 pm
  • Replies 16
  • Views 20980
Which database table holds the default group indicator? (OpenCart 3.0.2.0)

Hello all, I wrote some SQL scripts to convert my 1.4.9.3 store database to 3.0.2.0, and everything works great. However, the default customer group is no longer the Default group, but a different group. I know how to set/change the default group in the store settings in the admin panel, but I want ...

Jump to post
  • Sun Dec 30, 2018 11:05 am
  • Replies 4
  • Views 309

Search found 248 matches