Search found 1244 matches

Search found 1244 matches

Re: [v.1.5.6.4 database issue] order_product_id = order_id

As far as I can see the order_product table is only written to in the following places. Only one of which set a value for order_product_id, the other rely on the database to auto increment. https://github.com/opencart/opencart/blob/1.5.6.4/upload/admin/model/sale/order.php#L86 https://github.com/ope...

Jump to post
  • Mon Aug 10, 2020 8:04 pm
  • Replies 1
  • Views 91
Re: Upgrade Error 1091

I receive this error when trying to upgrade. I mention I just tried to access the admin panel when it took me straight to this upgrade page and when I hit upgrade it guves this error. I mention I do not know SQL. This is for a client. I searched on Google and I couldn't find no answer for this issu...

Jump to post
  • Thu Aug 06, 2020 9:05 pm
  • Replies 15
  • Views 598
Re: Customer order history displaying someone else's order and account info opencart 2.3.0.2

To check your servers PHP session settings you would need to upload a file to same directory as your OpenCart index.php called something like information.php. With the following in.

Code: Select all

<?php phpinfo(); ?>
Then go to that file in a web browser, find the session section and check the settings.

Jump to post
  • Wed Aug 05, 2020 7:42 pm
  • Replies 5
  • Views 657
Re: Anyone know why my shopping cart works fine on everything, except Microsoft Edge? using Version 3.0.3.2

Could be a session cookie or cache issue. Check your web browser's development console for errors and look at the response headers.

Jump to post
  • Tue Aug 04, 2020 12:05 am
  • Replies 11
  • Views 510
Re: OC 3.0.2.0 Error Log Question

For the first error see. https://forum.opencart.com/viewtopic.php?f=202&t=200896&start=20#p710221 The other errors are probably because you are displaying errors. To ensure no errors are being displayed, a must for any live stores, you need to do all of the following. 1. Set the PHP display_errors s...

Jump to post
  • Mon Aug 03, 2020 7:37 pm
  • Replies 2
  • Views 146
Re: Page links use http instead of https even when SSL is configured for the site

jstuardo wrote:
Fri Jul 31, 2020 3:36 am
As a side note for OpenCart developers. Maybe they could consider, if someone configures the store to use SSL, if an http request is received, platform could redirect to https counterpart.
That's probably best done in the .htaccess, as you will want to redirect requests for static files as well.

Jump to post
  • Fri Jul 31, 2020 5:05 am
  • Replies 14
  • Views 353
Re: google_sitemap , error on line 1 at column 10834: xmlParseEntityRef: no name

At the two line here. https://github.com/opencart/opencart/blob/4ba536198a4638b6d3902a7c720ce8503b0dc394/upload/catalog/controller/extension/feed/google_sitemap.php#L22-L23 Replace. $product['name'] With. htmlspecialchars($product['name'], ENT_COMPAT | ENT_XML1, 'UTF-8') However, you may be better f...

Jump to post
  • Fri Jul 31, 2020 3:55 am
  • Replies 13
  • Views 2872
Re: google_sitemap , error on line 1 at column 10834: xmlParseEntityRef: no name

What version of OpenCart? Any modifications? It's probably an unescaped & in your product data somewhere. Thanks, I am using Version 3.0.3.2 , is there any easy way to find the & ? I do have a lot of extensions , and I am using SEO generator, maybe the problem is from that extension You could direc...

Jump to post
  • Fri Jul 31, 2020 12:58 am
  • Replies 13
  • Views 2872
Re: google_sitemap , error on line 1 at column 10834: xmlParseEntityRef: no name

What version of OpenCart? Any modifications?

It's probably an unescaped & in your product data somewhere.

Jump to post
  • Thu Jul 30, 2020 8:25 pm
  • Replies 13
  • Views 2872
Re: So where do i download Opencart 2.3.0.2 from?

That's not for the 2.x branch. You have pulled code from the 3.x branch without understanding the differences or testing. The key is passed into the constructor in 2.x. https://github.com/condor2/Opencart_2302/blob/3bae5ac4f68605ad8191e74d3860cc42d9dd1639/upload/catalog/controller/startup/startup.ph...

Jump to post
  • Sat Jul 25, 2020 3:32 am
  • Replies 8
  • Views 644
Re: So where do i download Opencart 2.3.0.2 from?

The encryption class seems to be wrong in the condor2 version. Looks like it's been copied from version 3 without testing.

Jump to post
  • Sat Jul 25, 2020 1:17 am
  • Replies 8
  • Views 644
Re: SQL Errors causing sensitive data exposure in Journal OpenCart Theme < 3.1.0

Thanks for posting. Looking at your blog post you mention the typecast of the page GET parameter as an integer and your recommended workaround being in catalog/model/journal3/blog.php. Don't you mean catalog/controller/journal3/blog.php? Also from reading your article, wouldn't a negative number as ...

Jump to post
  • Thu Jul 23, 2020 10:46 pm
  • Replies 8
  • Views 850
Re: Server Migration Woes...

Check the requests in the web browser's development tool network tab. When clearing log there should be a call to index.php?route=tool/log/clear which will return an 302 redirect status. Redirecting to index.php?route=tool/log which should return a 200 status. Both should not be cached, so check the...

Jump to post
  • Wed Jul 22, 2020 12:06 am
  • Replies 10
  • Views 576
Re: Is Opencart 3 more secure than previous versions?

There are some security fixes in the latest version 3.0.3.3. However, these are more related to securing customer data or customer payment credentials (when combined with the CSRF flaw that will never be fixed). It would be easier to back port these fixes than to upgrade. There are some security vul...

Jump to post
  • Sat Jul 18, 2020 12:58 am
  • Replies 11
  • Views 417
Re: Customer order history displaying someone else's order and account info opencart 2.3.0.2

If you login as those customer, via the admin, what order history do you see?

Are you using any theme, extensions or modifications that could affect sessions or caching?

Have you checked the PHP session settings, using phpinfo()? https://www.php.net/manual/en/session.configuration.php

Jump to post
  • Thu Jul 16, 2020 11:09 pm
  • Replies 5
  • Views 657
Re: Bank Transfer not showing

Have you refresh your modifications cache? Extensions -> Modifications -> Refresh (icon). Also try the theme cache, cog icon on dashboard.

Jump to post
  • Thu Jul 16, 2020 1:24 am
  • Replies 8
  • Views 423
Re: Error: MySQL server has gone away

Contact your host, it a database connection issue.

Jump to post
  • Wed Jul 15, 2020 11:36 pm
  • Replies 9
  • Views 7716

Search found 1244 matches