Post by quincy225 » Tue Apr 06, 2010 8:28 pm

Hoi,


Ik heb de IDEAL module van Opencart op deze website gedownload en ik krijg de volgende foutmelding bij het installeren.

Fatal error: Call to a member function https() on a non-object in /home/bcdimgjf/domains/mijndomein.nl/public_html/admin/controller/payment/mollie.php on line 68


Iemand enig idee hoe dit komt en hoe ik dit kan oplossen?

Newbie

Posts

Joined
Tue Apr 06, 2010 8:18 pm

Post by Gerrit » Sun Apr 11, 2010 3:12 am

Het is voor dit soort vragen altijd handig als je het versie nummer van OC vermeld. Als je bijvoorbeeld 1.4.6 gebruikt met de 1.4.0 ideaal module dan kan dit een probleem geven. Het versie nummer van OC kan je helemaal onderaan je pagina terug vinden.

G.

For modelcars cars see my OC 3.0.2.0 shop: http://www.gbcars.nl/
For Wooden Toys see my 2.3.0.2 shop: https://www.dehoutentreinenwinkel.nl/


User avatar
Active Member

Posts

Joined
Fri Nov 27, 2009 9:06 pm

Post by i2Paq » Sun Apr 11, 2010 4:01 am

Gerrit wrote:Het is voor dit soort vragen altijd handig als je het versie nummer van OC vermeld. Als je bijvoorbeeld 1.4.6 gebruikt met de 1.4.0 ideaal module dan kan dit een probleem geven. Het versie nummer van OC kan je helemaal onderaan je pagina terug vinden.

G.

Niet bij 1.4.0 ;)

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by ocram » Mon Apr 12, 2010 9:39 pm

quincy225 wrote:Hoi,


Ik heb de IDEAL module van Opencart op deze website gedownload en ik krijg de volgende foutmelding bij het installeren.

Fatal error: Call to a member function https() on a non-object in /home/bcdimgjf/domains/mijndomein.nl/public_html/admin/controller/payment/mollie.php on line 68


Iemand enig idee hoe dit komt en hoe ik dit kan oplossen?
Hoi,

Deze melding wijst erop dat je een oudere versie van de iDEAL-plugin gebruikt. Download de versie voor jouw versie van Opencart via janssencox.nl/mollie-ideal, hoogstwaarschijnlijk moet je v1.4.1+ hebben. Je kunt de bestanden gewoon overschrijven en dan zou het moeten werken. Als het dan nog niet werkt hebben we idd in ieder geval je OC en mollie-ideal versienummer nodig.

Gr. Marco

Newbie

Posts

Joined
Tue Sep 15, 2009 2:57 am
Location - The Netherlands

Post by yeuxbleus » Tue Apr 13, 2010 3:17 pm

Ik heb het zelfde issue. Maar alleen met OC 1.4.7 Mollie 1.3_OC1.4+. In OC 1.4.6 werkt diezelfde Mollie naar behoren. (ook al per email gemeld met verdere details). Overigens bevatten de notes in alle files nog een verwijzing naar een oudere versie van Mollie.

Bij confirmen:
Error: Fatal error Cannot redeclare class ControllerPaymentMollie in /catalog/language/english/payment/mollie.php on line 151 (vreemd genoeg ik iedere taal de verwijzing naar de .../english/.... - file is gewoon aanwezig)

En in de testomgeving wordt bij confirmen een index-x.php geopend.

Mvg,
Maarten

User avatar
Newbie

Posts

Joined
Wed Mar 24, 2010 6:45 pm

Post by ocram » Tue Apr 13, 2010 4:50 pm

De Mollie plugin blijkt inderdaad NIET compatible te zijn met OC 1.4.7. De problemen die hier omschreven worden komen naar boven als de oude versie in een OC 1.4.7 shop wordt gezet. Ik ga de komende dagen aan de slag om de plugin om te schrijven zodat hij wel goed met 1.4.7 werkt. De nieuwe versie komt zogauw hij klaar is op onze website (http://www.janssencox.nl/ideal-mollie).

Gr. Marco

Newbie

Posts

Joined
Tue Sep 15, 2009 2:57 am
Location - The Netherlands
Who is online

Users browsing this forum: No registered users and 3 guests