Post by emergencyled » Fri May 30, 2014 8:14 am

I am new to the forum and have searched/googled but can't find an answer. I have 1.5.6.1 and am trying to test the paypal function. I have setup sandbox accounts and the flow is perfect if you fill out the billing, shipping , agree to terms section of opencart and then select paypal as a payment option. The problem arises when I use the express button when I first enter the checkout process. The paypal flow is fine and returns to my site for confirmation, when you click confirm it returns to the beginning of the checkout process and the items are still in cart. I do know it does not give me the oppurtunity to agree to terms but I disabled that requirement and it has same issue. Also upon return to my site if I proceed with guest checkout it seems to have the test account billing info with no phone# or State which are normally required, thinking this couold be a problem. Not sure if I go live if the problem will go away but trying to fully test.

Any idea much appreciated, thanks

Newbie

Posts

Joined
Fri May 30, 2014 7:55 am

Post by emergencyled » Fri May 30, 2014 9:22 am

Not sure if this is related but error log has the following:

PHP Notice: Undefined index: pp_express in ......../store/catalog/controller/payment/pp_express.php on line 707

Line 707 has this line of code:

$this->session->data['payment_method'] = $this->session->data['payment_methods']['pp_express'];

Newbie

Posts

Joined
Fri May 30, 2014 7:55 am

Post by blocks1 » Tue Dec 04, 2018 2:04 am

did you ever find the solution to this issue?

New member

Posts

Joined
Thu Feb 08, 2018 11:14 am
Who is online

Users browsing this forum: No registered users and 9 guests