Post by aschakel » Mon Jun 17, 2019 2:43 pm

Hello,

I'm looking for a developer that can help me out.

I have this webshop: www.approvedsneakers.com and it's not really much products or something, just a simple setup with +/- 200 products.

But, the shop is loading superslow, like 16sec each click. I've tried everything, from htaccess things to breaking down the installed plugins.
Nothing helps.

We do use some plugins like: X-Fee Pro, Enhanced Analytics,
We don't use any weird plugins.
The caching of Journal is turned on.
The Htaccess setup is good (for what I know).

The backend and the frontend are slowly loading.

The GTmetrix you'll see: https://gtmetrix.com/reports/www.approv ... m/lo24xo6h

Anyone that want to help me with this?

New member

Posts

Joined
Fri Apr 15, 2011 6:04 pm

Post by uksitebuilder » Mon Jun 17, 2019 3:08 pm

If the backend is also as slow, then I would think it is most likely a hosting issue.

ImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by wrick0 » Mon Jun 17, 2019 3:18 pm

Make sure to disable category product count, will speed it up a lot!

enable the journal cache, and try the lightning cache module it gives my site 100/100 on pagespeed (its free to try).

https://lightning.devs.mx/

Before these changes my site was very slow too

Active Member

Posts

Joined
Fri Jan 18, 2019 10:00 pm
Location - 127.0.0.1 @ The Netherlands

Post by thekrotek » Mon Jun 17, 2019 3:38 pm

No, do NOT install lightning cache, it bloats your system. With 200 products you don't need ANY caching at all. Like you've previously been told, problem might be with your hosting or server. Do a simple test, install clear OpenCart and try to load your products in it, see, how it goes. =

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by aschakel » Mon Jun 17, 2019 3:54 pm

Thanks for the replies.

- I've disabled the Category Count, but that is not giving any better speed.
- It could be an hosting-issue, but we are at one of the top dutch hosting companies. Maybe we need a bigger 'package', but the shop is not that 'big'.

The 'wait' time is really the problem I think. I do have multiple shops with the same kind of setup, that are loading fast.

New member

Posts

Joined
Fri Apr 15, 2011 6:04 pm

Post by thekrotek » Mon Jun 17, 2019 4:05 pm

aschakel wrote:
Mon Jun 17, 2019 3:54 pm
The 'wait' time is really the problem I think. I do have multiple shops with the same kind of setup, that are loading fast.
If your other shops are on the same server, problem might be with some extension. Neither your product quantity, nor Journal theme (the slowest theme of them all) doesn't look like a root of the problem.

In this case. I'm afraid, the only way to solve this is to look into this personally. I can do this for you, drop me an email or text in Skype, if interested.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by JNeuhoff » Mon Jun 17, 2019 5:42 pm

As was suggested in this forum thread, try to install a plain OpenCart 3.0.3.2 server (use 3.0.3.2 rather than 3.0.3.1 because it has bugfixes!) and then test it out, to see whether it still has the performance issues. If it doesn't, then you know that it is not an issue with the webhost. The next step would then be a process of elimination of all your 3rd party extensions. Also notice Journal is one of the most cumbersome web themes out there, so you might also want to do a test with OpenCart's default theme, just to see whether it makes any difference.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by paulfeakins » Mon Jun 17, 2019 7:34 pm

aschakel wrote:
Mon Jun 17, 2019 2:43 pm
I'm looking for a developer that can help me out.
If you're looking to pay a developer for this, you can look at the Commercial Support Forum and you are of course welcome to contact us: info@antropy.co.uk

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by letxobnav » Tue Jun 18, 2019 12:14 am

fix your CORS issues first

Access to font at 'https://approvedsneakers.com/catalog/vi ... ttf?gzj9ot' from origin 'http://www.approvedsneakers.com' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by thekrotek » Tue Jun 18, 2019 2:43 am

By the way, your store loads pretty fast for me. Have you changed something?

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by waylander1398 » Tue Jun 18, 2019 5:29 am

Are you installed lots of vqmod extensions?
Or x-shipping?
If yes check the size of the file "checked.cache"
In vqmod folder of your website
If it is upper than usaual delete it and rebuild the cache in modification menu

New member

Posts

Joined
Tue Mar 12, 2019 5:12 am

Post by aschakel » Mon Jul 08, 2019 10:46 pm

Thanks to all of you.

I switched three times from hosting platfoms, to see if some other server was doing a better job.
In the beginning it was fast, and then after a week or so..it becomes slow. So slow, that the last
VPS we are on now, was going down because of 100% CPU usage.

This last option of deleting 'checked.cache' is something that give some speed back indeed! It was 33MB and now it's 96KB.

Is this something that I must delete sometimes?

- We don't use a lot of plugins, only X-Fee Pro and Enhanced E-Commerce Tracking.

New member

Posts

Joined
Fri Apr 15, 2011 6:04 pm

Post by OSWorX » Mon Jul 08, 2019 10:54 pm

aschakel wrote:
Mon Jul 08, 2019 10:46 pm
Thanks to all of you.

I switched three times from hosting platfoms, to see if some other server was doing a better job.
In the beginning it was fast, and then after a week or so..it becomes slow. So slow, that the last
VPS we are on now, was going down because of 100% CPU usage.

This last option of deleting 'checked.cache' is something that give some speed back indeed! It was 33MB and now it's 96KB.

Is this something that I must delete sometimes?

- We don't use a lot of plugins, only X-Fee Pro and Enhanced E-Commerce Tracking.
Which OpenCart Version are you using now exactly?
With some there is an issue with the session table!

And checked.cache indicates that you are using VQmod - why?
Are you sure you are using the correct VQMod version for the used OpenCart Version (that makes a big difference, especially if your storage folder is out the public structure).

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by naderbissani » Wed Jan 20, 2021 11:56 am

JNeuhoff wrote:
Mon Jul 08, 2019 10:57 pm
You could use the Integrated VQMod which doesn't use the 'vqmod/checked.cache'.
Hi. I have a similar problem. Do you do paid support?

Newbie

Posts

Joined
Sun Jan 12, 2014 3:21 am
Who is online

Users browsing this forum: No registered users and 4 guests