Post by DANDTON » Sun Mar 15, 2015 4:03 pm

Hello All,
I am using 1.5.6, I found there is a bug, please take a look:
1, I set up the "Weight Based Shipping" as the picture show, the unit is KG, so you can see when 0.15kg, the shipping fee is 5.98$. when 0.20kg, the shipping fee is 8.99$.
2, I test this function, and found problem: I added 3 items in cart and check out, suddenly found the shipping fee is 8.99$, it should be 5.98$, because each item's weight is 0.05 what I set in the "Date" label. Please look at the picture.
3, But when I bought 5, 6, 7 or more items, the shipping fee is right, only when I bought 3 items, this problem came out.
I need help friends, who can solve this problem please?
Thank you all!

Attachments

ccc.jpg

ccc.jpg (40.61 KiB) Viewed 324 times

bbb.png

bbb.png (1.95 KiB) Viewed 324 times

aaa.png

aaa.png (2.93 KiB) Viewed 324 times


Newbie

Posts

Joined
Sun Mar 15, 2015 3:55 pm

Post by fido-x » Tue Mar 17, 2015 9:38 am

Not a bug, merely a misunderstanding of how things work.
DANDTON wrote:... so you can see when 0.15kg, the shipping fee is 5.98$. when 0.20kg, the shipping fee is 8.99$.
When the weight is LESS THAN 0.15kg the shipping fee is $5.98, when the shipping fee is EQUAL TO or GREATER THAN 0.15kg and LESS THAN 0.20kg the shipping fee is $8.99.

You need to set your weight breaks accoridingly, eg. 0.16:5.98, 0.21:8.99, etc.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia
Who is online

Users browsing this forum: No registered users and 4 guests