Post by Simple » Thu Sep 02, 2010 2:22 am

Getting this error since upgrading....

Notice: Undefined index: VendorTxCode in /***/*****/*******/catalog/controller/payment/sagepay.php on line 148Warning: Cannot modify header information - headers already sent by (output started at /***/*****/******/index.php:92) in /***/*****/******/system/engine/controller.php on line 27

Payment goes through but the cart thinks the payment has not.
After paying that error above is displayed instead of returning to the store.

Any Ideas please
Last edited by i2Paq on Thu Sep 02, 2010 1:16 pm, edited 1 time in total.
Reason: Split, renamed and moved

User avatar
New member

Posts

Joined
Sun Jul 25, 2010 6:44 pm

Post by Qphoria » Thu Sep 02, 2010 2:44 am

Simple wrote:Getting this error since upgrading....

Notice: Undefined index: VendorTxCode in /***/*****/*******/catalog/controller/payment/sagepay.php on line 148Warning: Cannot modify header information - headers already sent by (output started at /***/*****/******/index.php:92) in /***/*****/******/system/engine/controller.php on line 27

Payment goes through but the cart thinks the payment has not.
After paying that error above is displayed instead of returning to the store.

Any Ideas please
Try restoring the one from 1.4.8b to your store and see if that fixes it

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Simple » Thu Sep 02, 2010 3:01 am

Qphoria wrote:
Try restoring the one from 1.4.8b to your store and see if that fixes it
Thanks for that I restored the old one and worked fine.

Problem line was this...This line worked in 1.4.8b

Code: Select all

Line 148				$this->model_checkout_order->confirm($this->request->get['order_id'], $this->config->get('sagepay_order_status_id'));
This Line breaks the gateway in 1.4.9

Code: Select all

Line 148				$this->model_checkout_order->confirm($data['VendorTxCode'], $this->config->get('sagepay_order_status_id'));
Just thought I'd post and let you know. Thanks for the prompt reply.

User avatar
New member

Posts

Joined
Sun Jul 25, 2010 6:44 pm

Post by Qphoria » Thu Sep 02, 2010 4:02 am

Simple wrote:
Qphoria wrote:
Try restoring the one from 1.4.8b to your store and see if that fixes it
Thanks for that I restored the old one and worked fine.

Problem line was this...This line worked in 1.4.8b

Code: Select all

Line 148				$this->model_checkout_order->confirm($this->request->get['order_id'], $this->config->get('sagepay_order_status_id'));
This Line breaks the gateway in 1.4.9

Code: Select all

Line 148				$this->model_checkout_order->confirm($data['VendorTxCode'], $this->config->get('sagepay_order_status_id'));
Just thought I'd post and let you know. Thanks for the prompt reply.

oddly I changed it because someone was saying that didn't work. Ok I'll change it back

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 12 guests