Post by leemcgee » Sun Jan 20, 2019 11:54 pm

https://harmony-air.com, my store, yields the 403 error:

Forbidden
You do not have permission to access /index.html on this server.

"index.html"? But opencart is PHP!

Please help, the site works if http, but also my browsers today all point to https not http for harmony.air.com, yesterday they pointed to and worked in http not secure, but today the store goes to https!

Thank you, Lee leemcgee

New member

Posts

Joined
Mon Oct 17, 2016 6:00 am
Location - Mount Aukum, CA

Post by xxvirusxx » Mon Jan 21, 2019 12:04 am

You made changes in config.php?
Or .htaccess

My converted modules | Buy me a beer | Opencart upgrade service


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by leemcgee » Mon Jan 21, 2019 4:07 am

Both have some changes in them, here they are right here:
.htaccess
------------
[root@harmonynet public_html]# cat .htaccess_bad
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(cart/|checkout/) https://%{HTTP_HOST}%{REQUEST_URI}

(only had the cart/checkout https ReWrite in it)

config.php
--------------
[root@harmonynet public_html]# cat config.php
<?php
// HTTP
define('HTTP_SERVER', 'http://harmony-air.com/');

// HTTPS
define('HTTPS_SERVER', 'https://harmony-air.com/');

// DIR
define('DIR_APPLICATION', '/var/www/harmony-air.com/public_html/catalog/');
define('DIR_SYSTEM', '/var/www/harmony-air.com/public_html/system/');
define('DIR_IMAGE', '/var/www/harmony-air.com/public_html/image/');
define('DIR_LANGUAGE', '/var/www/harmony-air.com/public_html/catalog/language/');
define('DIR_TEMPLATE', '/var/www/harmony-air.com/public_html/catalog/view/theme/');
define('DIR_CONFIG', '/var/www/harmony-air.com/public_html/system/config/');
define('DIR_CACHE', '/var/www/harmony-air.com/public_html/system/storage/cache/');
define('DIR_DOWNLOAD', '/var/www/harmony-air.com/public_html/system/storage/download/');
define('DIR_LOGS', '/var/www/harmony-air.com/public_html/system/storage/logs/');
define('DIR_MODIFICATION', '/var/www/harmony-air.com/public_html/system/storage/modification/');
define('DIR_UPLOAD', '/var/www/harmony-air.com/public_html/system/storage/upload/');
define('DIR_CATALOG', '/var/www/harmony-air.com/public_html/catalog/');

// DB
define('DB_DRIVER', 'mysqli');
define('DB_HOSTNAME', 'xxxxxxxxxxxx');
define('DB_USERNAME', 'oc');
define('DB_PASSWORD', 'xxxxxxxxx');
define('DB_DATABASE', 'xxxxxxxxx');
define('DB_PORT', '3306');
define('DB_PREFIX', 'oc_');

I also use Virtual Hosts in my server, virtual host conf files had the Redirect permanent command in them which redirects all http to https.

Redirect permanent / https://harmony-air.com

Lee leemcgee

New member

Posts

Joined
Mon Oct 17, 2016 6:00 am
Location - Mount Aukum, CA

Post by leemcgee » Mon Jan 21, 2019 4:43 am

This has actually now gotten far worse, I am now receiving the HTTP 500 Server Error generic apache message from the browser! NOT the index.html message received earlier! http still works fine, I have been trying to install certificate for https on my server (Centos/Apache) but has not been successful yet. Lee leemcgee

New member

Posts

Joined
Mon Oct 17, 2016 6:00 am
Location - Mount Aukum, CA

Post by Rob Assink » Mon Jan 21, 2019 2:41 pm

Don' show your database username and password. Remove them.

New member

Posts

Joined
Wed Dec 17, 2014 11:00 pm

Post by uksitebuilder » Mon Jan 21, 2019 3:50 pm

Removed DB details. I suggest you change them to something else now just in case.

ImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by wrick0 » Mon Jan 21, 2019 4:21 pm

Check your error logs, error 500 is a generic webserver error. You might have to turn on error reporting in php.ini to see the exact error. We might be able to help you then

Active Member

Posts

Joined
Fri Jan 18, 2019 10:00 pm
Location - 127.0.0.1 @ The Netherlands

Post by leemcgee » Wed Jan 23, 2019 12:46 am

I found the source of the 500 errors I had some typos in ssl.conf file, all fixed now.

But https still giving me the ERR_SSL_PROTOCOL_ERROR error, I still need to figure out why! I had been installing certificates which is what created my errors!

Thank you all for removing my database user/password details from these posts! Oops! I really appreciate your help. Lee leemcgee

New member

Posts

Joined
Mon Oct 17, 2016 6:00 am
Location - Mount Aukum, CA
Who is online

Users browsing this forum: No registered users and 30 guests