Post by Spud5 » Fri Apr 02, 2021 1:26 pm

Since yesterday morning my opencart shop is down due to it showing a white page on the index or front page. One can access the shop by using links from another site and remarkably an order has been placed and a new customer has signed up!
Yum updates were performed on the server the night before this happened although nothing is being shown in the logs
How does one rectify this error please? What causes this error?

New member

Posts

Joined
Mon May 23, 2016 8:17 pm

Post by thekrotek » Fri Apr 02, 2021 1:47 pm

There's always something in the logs, just different ones. Check your other (parent, server) error log.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by Spud5 » Fri Apr 02, 2021 2:00 pm

According to the server team there is nothing in the logs below is their most recent reply:
However, it is difficult to say what is happening because there are no errors being sent to the logs by the application. The error log the shop/ root does not show anything outside of the tests we ran.

Can you check if there's a debugging option in your application that you can enable in order for all errors to get logged?

Once some type of error reporting is enabled then we should be able to see why the index page isn't loading.
Thank you for your reply,

New member

Posts

Joined
Mon May 23, 2016 8:17 pm

Post by thekrotek » Fri Apr 02, 2021 2:31 pm

Your server team doesn't seem to be smart enough. Might worth changing the hosting company.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by xxvirusxx » Fri Apr 02, 2021 2:59 pm

If the server team made some server updates, why not fix the problem?

LE. Better check if PHP version was changed in Cpanel.

My converted modules | Buy me a beer | Opencart upgrade service


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by Cue4cheap » Fri Apr 02, 2021 10:29 pm

Spud5 wrote:
Fri Apr 02, 2021 1:26 pm
Since yesterday morning my opencart shop is down due to it showing a white page on the index or front page. One can access the shop by using links from another site and remarkably an order has been placed and a new customer has signed up!
Yum updates were performed on the server the night before this happened although nothing is being shown in the logs
How does one rectify this error please? What causes this error?
'White page' is usually a server error. There should be an 'error_log' file on the public_html, or store root folder. FTP to your account and look for an error log and see what it says.
Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by straightlight » Fri Apr 02, 2021 10:46 pm

Based on server changes, if using cPanel, also look in your ./logs/*.tar.gz files in the access logs for latest error entries.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by paulfeakins » Tue Apr 06, 2021 6:21 pm

Spud5 wrote:
Fri Apr 02, 2021 1:26 pm
How does one rectify this error please? What causes this error?
You should have support from an OpenCart developer such as ourselves or post a job in the Commercial Support Forum.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: No registered users and 18 guests