Post by Msdbl » Mon May 03, 2021 12:06 pm

Hello, My store just shows a msg on phone.
"YourPHP installation appears to be missing the Mysql extension with is required by Wordpress "
when I try to access it. Being a newbie to this and after looking all over the forums and net for advice am asking if anyone has an idea of my issue?
I am running 3.0.0.7 PHP 7.4 Any help would be much appreciated. Thank you
Last edited by Msdbl on Wed May 12, 2021 7:17 pm, edited 1 time in total.

Newbie

Posts

Joined
Sat Apr 17, 2021 10:42 pm

Post by thekrotek » Mon May 03, 2021 2:23 pm

Error message tells you everything you need to know.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by Msdbl » Mon May 10, 2021 3:05 am

Hello and thanks so far for your help. I have checked with my Hosts and they have said the following ...
" We have checked the server settings and we can see that the mysqli extension is already enabled on the server, this means that the website has not been configured correctly for mobile devices and will need to be fixed by yourself or with the assistance of a developer. "
So now wondering where in Opencart I can fix this so that the PHP message doesn't show on Phone and my website does. Any help would be much appreciated?
Best Martin

Newbie

Posts

Joined
Sat Apr 17, 2021 10:42 pm

Post by JNeuhoff » Mon May 10, 2021 4:03 pm

YourPHP installation appears to be missing the Mysql extension with is required by Wordpress
First of all, this is an OpenCart forum, for wordpress support go here.

I am running 3.0.0.7
There is no 3.0.0.7 version of OpenCart.

Unless you can give us some proper details nobody will be able to help you here.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Msdbl » Wed May 12, 2021 12:04 am

Thanks again. IT is Opencart 3.0.3.7 my apologies, I am just using Opencart for the shop. 7.4 PHP on the server and The host has said that the Mysql is working.
The website is joint-genie.com if that might be of help? Any other info I can provide please ask? Thank you for your patience. Best Martin

Newbie

Posts

Joined
Sat Apr 17, 2021 10:42 pm

Post by by mona » Wed May 12, 2021 12:25 am

Hi Martin,

Thank you for providing details. That is always useful and required in most cases.

May I make a few suggestions to assist you in getting the best out of this forum.
1. ALWAYS include your OC version in all four digits - as you have now done - thank you
2. ALWAYS include any relevant extensions / themes / modules that may effect this
3. Try to use a title that accurately describes the problem. The problem is not on your phone - this is misleading - so having provided a web address we can work that out, so it is always useful to provide a web address.

Now on to your problem.
"YourPHP installation appears to be missing the Mysql extension with is required by Wordpress "
Your issue is your php version and with an extension within wordpress. Search google, but I believe this will help you resolve your issue:
https://wpbuffs.com/php-installation-mi ... wordpress/

Kind regards,

PS It is forum etiquette to add [SOLVED] to the title when it is.
PPS. Your Opencart shop is working both on a desktop and a mobile - it is under the directory /shop2

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by Msdbl » Wed May 12, 2021 11:12 am

Thanks Mona for you pointing things out. I have read the link and checked and changed all PHP versions below 7.3 doesn't work at all. 8 is the same. Here is the php .ini file
magic_quotes_gpc = Off
register_globals = Off
default_charset = UTF-8
memory_limit = 64M
max_execution_time = 36000
upload_max_filesize = 999M
safe_mode = Off
mysql.connect_timeout = 20
session.auto_start = Off
session.use_only_cookies = On
session.use_cookies = On
session.use_trans_sid = Off
session.cookie_httponly = On
session.gc_maxlifetime = 3600
allow_url_fopen = On
;display_errors = 1
;error_reporting = E_ALL

Not sure if that helps but you say it works on a mobile but when I look is just shows the error msg (in previous post). I have had a few customers comment on it too. Hope that I am nearly there? Best Martin

Newbie

Posts

Joined
Sat Apr 17, 2021 10:42 pm

Post by Msdbl » Wed May 12, 2021 11:30 am

Just to Add - Uploaded a info.php file and this is the result - Now I am confused :crazy:
{\rtf1\ansi\ansicpg1252\cocoartf2513 \cocoatextscaling0\cocoaplatform0{\fonttbl\f0\fnil\fcharset0 Menlo-Regular;} {\colortbl;\red255\green255\blue255;\red51\green54\blue57;} {\*\expandedcolortbl;;\cssrgb\c25882\c27451\c28627;} \paperw11900\paperh16840\margl1440\margr1440\vieww10800\viewh8400\viewkind0 \deftab720 \pard\pardeftab720\partightenfactor0 \f0\fs36 \cf2 \expnd0\expndtw0\kerning0 }
Any Ideas please.....?

Newbie

Posts

Joined
Sat Apr 17, 2021 10:42 pm

Post by by mona » Wed May 12, 2021 11:54 am

This is OPENCART (your shop) = joint-genie.com/shop2 and it works on a mobile (my iPhone)
Screen-Shot-2021-05-12-at-04.42.48.png

Screen-Shot-2021-05-12-at-04.42.48.png (242.82 KiB) Viewed 215 times

This is WORDPRESS (wordpress site) : your main site = joint-genie.com - redirects to = joint-genie.com/jgmain/index.php.
Screen-Shot-2021-05-12-at-04.43.06.png

Screen-Shot-2021-05-12-at-04.43.06.png (16.51 KiB) Viewed 215 times

Your WORDPRESS site does not work - you are on the wrong forum to ask about wordpress - you need to ask
https://wordpress.org/support/forums/

But I think that either you have not updated your wordpress or one of your wordpress extension is not compatible, but you need to ask in the wordpress forum not here.

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by ADD Creative » Wed May 12, 2021 4:34 pm

Looks like there are issues with the redirects on your site. I get redirected to https://joint-genie.com/shop2//index.ph ... ommon/home. Note the double // and no www. It could be they your site is redirecting based on user agent or IP address.

You need to check your redirects in you .htaccess files and you hosting.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by Msdbl » Wed May 12, 2021 7:13 pm

Hello Mona, again thank you for your knowledge. Yes I think you are right , I have looked at the previous files on the server and it seems I have old Wordpress files from our old shop that seems to be there and are conflicting. I think I need to do a spring clean !! Thank you again for all your help and perseverance! I will add solved to the Subject line. Best Martin

Newbie

Posts

Joined
Sat Apr 17, 2021 10:42 pm
Who is online

Users browsing this forum: No registered users and 8 guests