Post by tapir47 » Tue May 18, 2021 6:29 pm

Opencart 3.0.3.7
Default template
PayPal Express issue in live mode

Hi
I had a live 2.0.3.1 site which was working fine with PayPal Express in live and sandbox modes. I decided to upgrade it to 3.0.3.7 in a subdomain and tested it and everything was fine including PayPal. The site was then copied and config files adjusted to the main domain and the site itself works but payments are not happening. When going through checkout the PayPal popup is displayed, log in is fine but click on the Pay Now button and the Popup displays Processing and never returns.

I've turned on Paypal debug logging in the extension and comparing SandBox (which works) with live, calls are not happening (entries edited to retain the flow but removed information):

Sandbox

Code: Select all

2021-05-18 9:05:41 - PayPal Express debug (Call data): {"METHOD":"SetExpressCheckout","MAXAMT":....
2021-05-18 9:05:44 - PayPal Express debug (Result): "TOKEN=EC%2d0GG742763H9796727&TIMESTAMP=2021%2d05%2d18T08%3a05%3a44Z&CORRELATIONID=f112484a2963&ACK=Success&VERSION=109%2e0&BUILD=55627781"
2021-05-18 9:06:32 - PayPal Express debug (Call data): {"METHOD":"GetExpressCheckoutDetails","TOKEN":"EC-0GG742763H9796727"}
2021-05-18 9:06:33 - PayPal Express debug (Result): "TOKEN=EC%2d0GG742763H9796727&BILLINGAGREEMENTACCEPTEDSTATUS=0&CHECKOUTSTATUS=PaymentActionNotInitiated....
2021-05-18 9:06:33 - PayPal Express debug (Call data): {"TOKEN":"EC-0GG742763H9796727","PAYERID":"BWQPVCPG4852N","METHOD":"DoExpressCheckoutPayment","PAYM.....
2021-05-18 9:06:38 - PayPal Express debug (Result): "TOKEN=EC%2d0GG742763H9796727&SUCCESSPAGEREDIRECTREQUESTED=false&TIMESTAMP=2021%2d05%2d18T08%3a06%3a38Z&CORRELATIONID=763070f19f7ed&ACK=Success&VERSIO......
Live

Code: Select all

2021-05-18 9:04:12 - PayPal Express debug (Call data): {"METHOD":"SetExpressCheckout","MAXAMT":...
2021-05-18 9:04:13 - PayPal Express debug (Result): "TOKEN=EC%2d11T3251991275311K&TIMESTAMP=2021%2d05%2d18T08%3a04%3a13Z&CORRELATIONID=df350c7e2081a&ACK=Success&VERSION=109%2e0&BUILD=55627781"
Any ideas why the PayPal flow is not happening correctly in live mode. All PayPal details have been checked and re-entered. Multiple browsers tried with the same result. I am not aware of PayPal having an issue and this has been happening for 24 hours now. Any suggestions gratefully received.

Newbie

Posts

Joined
Tue May 18, 2021 5:16 pm

Post by ADD Creative » Wed May 19, 2021 4:02 am

PayPal Express is broken in 3.0.3.3 and above. See https://github.com/opencart/opencart/pull/8164. You could try using the files from your old version.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by tapir47 » Thu May 20, 2021 4:40 pm

I've switched to PayPal Payments Standard which seems to be working for me. I'm more than a little concerned that PayPal Express has been known to be broken for a year with 3 patches since 3.0.3.3. I know OpenCart is opensource and relies on the time and support of developers giving their own time but for a major payment gateway to be included in the package when it is known to be suspect in operation with no information in release notes or anything like that is really quite dangerous and damaging to the reputation of OpenCart in my opinion.

Newbie

Posts

Joined
Tue May 18, 2021 5:16 pm

Post by ADD Creative » Thu May 20, 2021 9:28 pm

You will find that sort of thing happening with OpenCart. It's developed by one developer who concentrates on the latest version. Other developers take on the maintenance releases from time to time, but don't last too long due amount of time involved or being out of their depth.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom
Who is online

Users browsing this forum: No registered users and 5 guests