Post by nicolasjw » Thu Nov 30, 2017 5:20 pm

After uploading the files and pointing to /install - I get the follwoing error:


Fatal error: Uncaught exception 'Exception' with message 'Error: Could not load template adaptor !' in /homepages/31/d39221108/htdocs/banyan/cart/system/library/template.php:28 Stack trace: #0 /homepages/31/d39221108/htdocs/banyan/cart/system/storage/modification/system/engine/loader.php(81): Template->__construct(NULL) #1 /homepages/31/d39221108/htdocs/banyan/cart/install/controller/common/header.php(14): Loader->view('common/header', Array) #2 [internal function]: ControllerCommonHeader->index(Array) #3 /homepages/31/d39221108/htdocs/banyan/cart/system/storage/modification/system/engine/action.php(51): call_user_func_array(Array, Array) #4 /homepages/31/d39221108/htdocs/banyan/cart/system/storage/modification/system/engine/loader.php(24): Action->execute(Object(Registry), Array) #5 /homepages/31/d39221108/htdocs/banyan/cart/install/controller/upgrade/upgrade.php(28): Loader->controller('common/header') #6 [internal function]: ControllerUpgradeUpgrade->index() #7 /homepages/31/d39221108/htdocs/banyan/cart/system/storage/ in /homepages/31/d39221108/htdocs/banyan/cart/system/library/template.php on line 28

Newbie

Posts

Joined
Thu Nov 30, 2017 5:19 pm

Post by straightlight » Fri Dec 01, 2017 8:25 am

It seem you attempted to run the upgrade process by keeping extensions installed since the modification folder, according to the error message above, still loads some files which should never be the case when upgrading Opencart. I would suggest to restore backups and seek for professional assistance in order to upgrade your store.

In the mean time, you can also view this post on how to proceed orderly: viewtopic.php?f=199&t=199983#p704794

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by KevM » Fri Jan 15, 2021 4:01 am

Hi

An old thread i know, but I encountered this error whilst upgrading from 2.3.0.2 to 3.0.3.6 and this fixed the error for me - https://interbiznw.com/2019/10/29/openc ... e-adaptor/

Hope that helps someone

Kev

Newbie

Posts

Joined
Wed Jun 08, 2011 3:17 am

Post by straightlight » Fri Jan 15, 2021 4:46 am

KevM wrote:
Fri Jan 15, 2021 4:01 am
Hi

An old thread i know, but I encountered this error whilst upgrading from 2.3.0.2 to 3.0.3.6 and this fixed the error for me - https://interbiznw.com/2019/10/29/openc ... e-adaptor/

Hope that helps someone

Kev
viewtopic.php?f=201&t=187326#p810607

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by KevM » Fri Jan 22, 2021 3:41 am

straightlight wrote:
Fri Jan 15, 2021 4:46 am
KevM wrote:
Fri Jan 15, 2021 4:01 am
Hi

An old thread i know, but I encountered this error whilst upgrading from 2.3.0.2 to 3.0.3.6 and this fixed the error for me - https://interbiznw.com/2019/10/29/openc ... e-adaptor/

Hope that helps someone

Kev
viewtopic.php?f=201&t=187326#p810607
I found the link that you posted and tried the suggestions in it, but they didn't work, the link that I posted did work and sorted the problem for me

Kev

Newbie

Posts

Joined
Wed Jun 08, 2011 3:17 am

User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by straightlight » Fri Jan 22, 2021 4:45 am

KevM wrote:
Fri Jan 22, 2021 3:41 am
straightlight wrote:
Fri Jan 15, 2021 4:46 am
KevM wrote:
Fri Jan 15, 2021 4:01 am
Hi

An old thread i know, but I encountered this error whilst upgrading from 2.3.0.2 to 3.0.3.6 and this fixed the error for me - https://interbiznw.com/2019/10/29/openc ... e-adaptor/

Hope that helps someone

Kev
viewtopic.php?f=201&t=187326#p810607
I found the link that you posted and tried the suggestions in it, but they didn't work, the link that I posted did work and sorted the problem for me

Kev
It's a false / positive (or infected) malicious website you posted.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 6 guests