Post by bodgybro » Wed Aug 19, 2020 10:03 am

Hi,
I have uploaded open cart v3.0.3.6 and chmod'd as per install.txt but when i go to main install.php page I get
PH7.3+ required.
I checked and my server is running PHP Version 7.3.17
So i'm stuck.
Any ideas?
Last edited by bodgybro on Thu Aug 20, 2020 6:17 pm, edited 1 time in total.

Newbie

Posts

Joined
Wed Aug 19, 2020 9:19 am

Post by letxobnav » Wed Aug 19, 2020 6:00 pm

maybe double-check with phpinfo().

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by ADD Creative » Wed Aug 19, 2020 6:38 pm

Upload you own PHP file that echos the PHP version to check.
https://www.php.net/manual/en/function.phpversion.php

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by bodgybro » Thu Aug 20, 2020 9:41 am

I tried that and used other variations i found through google... all i get is a blank page, nothing on it :/

Newbie

Posts

Joined
Wed Aug 19, 2020 9:19 am

Post by bodgybro » Thu Aug 20, 2020 9:46 am

wrote the code on the server instead of uploading a file. worked... shows 5.6.4 even tho my host control panel says 7.1.17 :/
emailing my host now
thank yo for the replies.

Newbie

Posts

Joined
Wed Aug 19, 2020 9:19 am

Post by bodgybro » Thu Aug 20, 2020 5:55 pm

Got hold of my host and showed them the phpinfo compared to their posted info, they updated me to 7.4.4 now.
Started to work on the install and hit zip extension needs to be loaded for opencart to work.... back to the host....

Newbie

Posts

Joined
Wed Aug 19, 2020 9:19 am

Post by khnaz35 » Thu Aug 20, 2020 6:00 pm

bodgybro wrote:
Thu Aug 20, 2020 5:55 pm
Got hold of my host and showed them the phpinfo compared to their posted info, they updated me to 7.4.4 now.
Started to work on the install and hit zip extension needs to be loaded for opencart to work.... back to the host....
Thanks for update!
Since your original Issue is done you can add the word [SOLVED] into the beginning of your post title. ;) :)

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by rushikeshnakhate » Sun Aug 30, 2020 10:29 pm

Hello , I am getting error PHP 7.3 is required while installing opencart , Can you please check what is the issue ?

I have tried to search online for the issue , but it is not clear to me how to solve the issue .


Posts

Joined
Wed Aug 22, 2018 4:39 pm

Post by ADD Creative » Mon Aug 31, 2020 2:20 am

Check your PHP version with.

Code: Select all

echo phpversion();
or

Code: Select all

phpinfo();
You need to put this in a .php file on your server and go to it in a web browser.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by khnaz35 » Mon Aug 31, 2020 10:19 am

rushikeshnakhate wrote:
Sun Aug 30, 2020 10:29 pm
Hello , I am getting error PHP 7.3 is required while installing opencart , Can you please check what is the issue ?

I have tried to search online for the issue , but it is not clear to me how to solve the issue .
What is your oc version?
Did you or your host made any recent changes into site?

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by BillionDollars » Wed Nov 25, 2020 1:06 am

Hi everyone.

My first time here.

I saw that this issue is solved, but I installed 3.0.3.6 on my local Linux Mint 19.3 and I have PHP7.4.12 on my pc, this is from the terminal.
(PHP 7.4.12 (cli) (built: Oct 31 2020 17:04:09) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
with Zend OPcache v7.4.12, Copyright (c), by Zend Technologies)

I get this message (PH7.3+ Required) on Crome browser when I want to install OpenCart.

On my server with Plesk I don't have this issue and previously I did run OpenCart on my localhost until Linux crushed and I reinstall it.

I tried all that what I read on this post but can't find a solution not even with searches on Google.

Blessings
BillionDollars


Posts

Joined
Mon Jan 27, 2020 2:40 am

Post by ADD Creative » Wed Nov 25, 2020 6:14 am

Put the following in a .php file in the same directory as OpenCart and go to it in a web browser. This will tell you your PHP version and give details on the configuration.

Code: Select all

<?php

phpinfo();

?>

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by ndim_pro » Mon Apr 12, 2021 4:56 pm

Check your htaccess file as it might be redirecting to the main domain. That was my case.

User avatar
New member

Posts

Joined
Fri Nov 04, 2016 4:49 pm
Location - Thessaloniki, Greece
Who is online

Users browsing this forum: No registered users and 11 guests