Post by todovan » Wed Mar 05, 2014 7:11 am

Good day.

I've been trying to change the language for my OpenCart install on a localserver (using XAMPP). But everytime i try to change it i get this error:
"Notice: Error: Could not load language spanish! in C:\xampp\htdocs\opencart\system\library\language.php on line 39"

and according to the plugin documentation the solution is to change the folder permissions but everytime i try to change it the permissions set back to "read-only".

Is there anyway to fix this?

Thanks in advance.

Newbie

Posts

Joined
Wed Mar 05, 2014 6:54 am

Post by butte » Thu Mar 20, 2014 6:31 pm

If the instructions happen to say 777 but you happen to be Stateside or in Canada or much of Europe or Australia, your server will probably not allow you to set 777, which is a security risk (anybody and everybody can read, write, and execute).

You can try changing language packs or asking the language author why his would not load.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by willows » Thu Mar 20, 2014 6:38 pm

xampp is on a windows machine and 777 permissions are unix ones.

The error says it all.

It cannot load the file :
It is not there, make sure the files are there.
It cannot be executed and it is present

To change the permissions of a file on windows you may need to be logged in as administrator

Make sure you have spanish enable in the admin.

Available for hire for maintenance, installs, hacks, SEO disasters, and integrations with epos, logistics and accounts systems.
Opencart Developers Ireland
Image


User avatar
New member

Posts

Joined
Sun Mar 17, 2013 5:19 am
Location - Dublin Ireland

Post by butte » Fri Mar 21, 2014 1:17 am

Touche, willows, starting actually with C:\ itself, in dead of night. todovan, which version of Windows are you on? You may need to check your user account's privileges to ensure that they are admnistrative, and then in the OC installation you may need to edit your policies. For that you can right-click the OC root directory and select security, then maneuver through the permissions that affect administrators and you. Since only the language .php file(s) won't execute, they seem to be absent. The .php extension itself is executing, just to get that far.

Another tack is to open the language files in a plain ascii text editor and merely resave them WITHOUT BOM.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am
Who is online

Users browsing this forum: No registered users and 42 guests