Post by moteey » Mon Jun 30, 2014 7:29 pm

Hi!

I have Opencart setup that includes 4 stores. Each store has its own domain:
1.) example.com (DEFAULT)
2.) example.co.uk
3.) example.si
4.) example.eu

My hosting provider is GoDaddy and I have purchased Multiple domains SSL certificate (for up to 5 domains).

In C-panel I created parked domains, so all extra domains point to /public_html folder.

For my default store (example.com), everything works fine. SSL is enabled and pages like login redirect to secure URL (https://example.com).

Problem appears when I want to set up other stores to use SSL too.
1.) I go to Settings and edit one of additional stores. In Server tab I set: "Use SSL" to "Yes".
2.) Next in General tab, I enter SSL Url: "https://example.co.uk".
3.) When I want to save changes, the admin page redirects to Store front and I get "The page you requested cannot be found!" message.
4.) I go back to admin and SSL Url for store I edited isn't saved.

If I go to browser and navigate to the secure URL of any aditional store (https://example.co.uk), then the green lock is shown in address bar, indicating that SSL connection works fine. However the browser displays the default store and its data instead of ".co.uk" aditional store.

I don't know, am I missing something? Should I write anything specific into config.php or .htaccess?
I have searched for a solution whole day, with no luck :(

Please help, I'm lost here!

Newbie

Posts

Joined
Mon Jun 30, 2014 6:52 pm

Post by sooty » Thu Oct 01, 2015 11:33 pm

I now have this problem as well, did you find a solution??

New member

Posts

Joined
Fri Sep 21, 2012 4:59 am

Post by ASG » Sat Oct 03, 2015 2:34 am

I assume in the config files(in the public_html and /admin folders) you have correctly entered the https URL against the following entry?

define('HTTPS_SERVER','https://example.com')

ASG
Active Member

Posts

Joined
Tue Sep 30, 2014 11:03 pm
Who is online

Users browsing this forum: No registered users and 45 guests