Post by Japparts » Fri Sep 30, 2011 7:05 am

keether wrote:I would like to make sub category images a different size than category images ? Does anyone know how to do this ?
I would like to know this aswell. I have just spent the last hour trying to figure it out but so far no joy! :(

New member

Posts

Joined
Fri Sep 16, 2011 8:49 am

Post by Japparts » Fri Sep 30, 2011 7:27 am

Forget that, just figured it out by taking the info from another post and adapting it and a bit of guesswork!

In the xml file find the lines

Code: Select all

$image = $this->model_tool_image->resize($result['image'], $this->config->get('config_image_category_width'), $this->config->get('config_image_category_height'));
Replace with

Code: Select all

$image = $this->model_tool_image->resize($result['image'], 90, 90);
90, 90 being the height and width you want the image displayed. Change this as per requirements. All I need to do now is figure out how to change the size of the shadow under the original size image

New member

Posts

Joined
Fri Sep 16, 2011 8:49 am

Post by Xciso » Fri Sep 30, 2011 8:10 pm

Where can i found the stylesheet code for this mod?
Like: "box-product box-subcat"

Does anyone know how to mod this to get diffent images for the categories?
I dont want the orginal images i have for my category.

Thanks!

Active Member

Posts

Joined
Fri Jul 15, 2011 5:20 am

Post by Japparts » Sat Oct 01, 2011 5:42 am

I have been having the same problem with the style sheet. The original code uses the image size in admin to control the size of the displayed image. The code I posted above changes the image size to something more manageable but the styling on the template is all wrong when the images are made smaller.

Can someone please give a breakdown and explain how/where the stylesheet needs changing as I have spent a good few hours guessing at things I dont really understand and not got anywhere. Some help on this would be great!

Thank you

New member

Posts

Joined
Fri Sep 16, 2011 8:49 am

Post by Japparts » Sun Oct 02, 2011 9:42 am

Anyone??? I`ve read a lot of posts on this forum about a variety of things. There is a lot of people with a lot of knowledge and i`m sure to those people the above question is something that is quite easy to do. If someone would be kind enough to share the knowledge that would be great!

New member

Posts

Joined
Fri Sep 16, 2011 8:49 am

Post by Degsey » Sun Oct 02, 2011 12:49 pm

If you would like to give us a URL to look at we can probably help you better

Live Long and Prosper!

Degsey :-]

Visit us at :

http://www.Supreme-Ink.com


User avatar
New member

Posts

Joined
Sun Jun 12, 2011 2:29 am
Location - North Carolina

Post by smitch6 » Wed Oct 05, 2011 12:07 am

anyone sorted this for the very latest version of OC please :)

thanks

www.pattestersuffolk.co.uk


Active Member

Posts

Joined
Sat Sep 17, 2011 2:46 pm


Post by teratyke » Wed Oct 05, 2011 12:14 am

smitch6 wrote:anyone sorted this for the very latest version of OC please :)

thanks
This is the mod I'm using for 1.5.1.3.1 (or whatever it is at the moment...) I can't remember if its changed from earlier versions, but this is working for me with a pretty much default install.

sub cat images

If it doesn't work try disabling any other mods first as there could be conflicts and its easier to troubleshoot just one thing at a time.
Good luck

Active Member

Posts

Joined
Sun Jun 12, 2011 3:05 pm

Post by smitch6 » Wed Oct 05, 2011 12:21 am

i was just saying on another thread i don't think any of my vqmods are working :~

www.pattestersuffolk.co.uk


Active Member

Posts

Joined
Sat Sep 17, 2011 2:46 pm


Post by smitch6 » Wed Oct 05, 2011 12:23 am

just tried your upload and got this error at the top of my page

Notice: Undefined variable: image in /home/steve/public_html/personalisedprinting.org.uk/store/vqmod/vqcache/vq2-catalog_controller_product_category.php on line 135Notice: Undefined variable: image in /home/steve/public_html/personalisedprinting.org.uk/store/vqmod/vqcache/vq2-catalog_controller_product_category.php on line 135Notice: Undefined variable: image in /home/steve/public_html/personalisedprinting.org.uk/store/vqmod/vqcache/vq2-catalog_controller_product_category.php on line 135

www.pattestersuffolk.co.uk


Active Member

Posts

Joined
Sat Sep 17, 2011 2:46 pm


Post by teratyke » Wed Oct 05, 2011 12:24 am

Default install/template?

Active Member

Posts

Joined
Sun Jun 12, 2011 3:05 pm

Post by smitch6 » Wed Oct 05, 2011 12:26 am

yes all default but i have tweaked it slightly to suit my needs

www.personalisedprinting.org.uk/store
if you want to look
only just installed it 2 weeks ago so still playing

www.pattestersuffolk.co.uk


Active Member

Posts

Joined
Sat Sep 17, 2011 2:46 pm


Post by teratyke » Wed Oct 05, 2011 12:28 am

Mmm. Did you try disabling your other mods first?

Active Member

Posts

Joined
Sun Jun 12, 2011 3:05 pm

Post by smitch6 » Wed Oct 05, 2011 12:30 am

no i just installed it lol

www.pattestersuffolk.co.uk


Active Member

Posts

Joined
Sat Sep 17, 2011 2:46 pm


Post by uksitebuilder » Wed Oct 05, 2011 12:31 am

Doesnt appear to be the latest version of OC - header still has jquery-ui-1.8.9.custom.min.js in it
1.5.1.3 uses jquery-ui-1.8.16.custom.min.js

Modifying core files and/or template files will not allow vqmod to work correctly

ImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by teratyke » Wed Oct 05, 2011 12:49 am

I just tried the mod on a fresh install of 1.5.1.3.1 and it works - (although it did throw an error which I'm investigating - not sure if this is due to a windows XAMPP install as I can't recreate on my live server).
Just try creating images for some of those subcategories and see if that makes any difference.
Sorry I only hack these mods together for my own use really, I'm no developer, so its take it as it comes really I'm afraid.
Rob

Active Member

Posts

Joined
Sun Jun 12, 2011 3:05 pm

Post by uksitebuilder » Wed Oct 05, 2011 1:03 am

Almost works fine apart from this error when clicking on the final category that has no further subcategories

Notice: Undefined variable: result in /htdocs/opencartdemo1513/vqmod/vqcache/vq2-catalog_controller_product_category.php on line 155

ImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by teratyke » Wed Oct 05, 2011 1:05 am

Ok fixed a minor bug - I think. the mod now checks that there is a subcategory image - that could have been the cause of your error.
Can you try this version please?
I've tested on a default install and all is good.

subcat images 1.5.1.3.1


Active Member

Posts

Joined
Sun Jun 12, 2011 3:05 pm

Post by teratyke » Wed Oct 05, 2011 1:07 am

uksitebuilder wrote:Almost works fine apart from this error when clicking on the final category that has no further subcategories

Notice: Undefined variable: result in /htdocs/opencartdemo1513/vqmod/vqcache/vq2-catalog_controller_product_category.php on line 155
yep confirmed - i've been using this for months without finding these errors. I'll have a gander..

Active Member

Posts

Joined
Sun Jun 12, 2011 3:05 pm

Post by uksitebuilder » Wed Oct 05, 2011 1:09 am

Sorry mate, same error with your last upload too

Notice: Undefined variable: result in /htdocs/opencartdemo1513/vqmod/vqcache/vq2-catalog_controller_product_category.php on line 162

It occurs when viewing the final category with or without products.

Demo store is default apart from your mod so no possible conflicts

ImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom
Who is online

Users browsing this forum: No registered users and 28 guests