Post by TexasGreg » Thu Dec 17, 2020 2:20 am

I'm using OC version 3.0.3.2. My shopping cart would bounce all over the place as I browsed the website. It would go from containing items to not containing items or from containing items and then containing different items. I fought with this for a long time until I found a locked thread here dated Oct 18, 2018 viewtopic.php?t=207498, from ADD Creative, that solved the problem. What baffles me is even in the latest version of OC this fix is not incorporated.

Here is the fix. Maybe it will be easier to find for others.

In system/framework.php find the following line at around line 74.

Code: Select all

$response->addHeader('Content-Type: text/html; charset=utf-8');
After that line add the following.

Code: Select all

$response->addHeader('Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0');
$response->addHeader('Pragma: no-cache');
You will might have to clear your browser cache as well.

New member

Posts

Joined
Sun Nov 11, 2018 9:30 pm

Post by straightlight » Thu Dec 17, 2020 2:53 am

Not a bug.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by TexasGreg » Thu Dec 17, 2020 4:36 am

straightlight wrote:
Thu Dec 17, 2020 2:53 am
Not a bug.
Not for me anymore. It was a big pain though.

New member

Posts

Joined
Sun Nov 11, 2018 9:30 pm

Post by EvolveWebHosting » Thu Dec 17, 2020 5:09 am

Is this only an issue for 3.0.2.0 or for all 3.x versions?

Image
50% Off SSD Shared Hosting w/ cPanel
Detailed guide on how to install Opencart


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by ADD Creative » Thu Dec 17, 2020 5:55 am

EvolveWebHosting wrote:
Thu Dec 17, 2020 5:09 am
Is this only an issue for 3.0.2.0 or for all 3.x versions?
All 3.x versions.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by TyRider » Sun Jan 24, 2021 12:22 pm

My checkout button was totally nuts. Every page I went to it said different checkout inventory. Removing items would magically reappear three or four pages later. I added the two lines of php and it resolved my issue. But broke some other stuff.

I renamed /system/storage to /system/this_stupid_folder_should_have_been_moved

And it fixed the flakey Shopping Cart.

Oh also, I renamed .htaccess.txt to .htaccess

Newbie

Posts

Joined
Sun Jan 24, 2021 12:00 pm
Who is online

Users browsing this forum: No registered users and 14 guests