Post by Jah22 » Wed Feb 24, 2021 8:30 am

1. Version
2. Default Theme
3. ClearThinking Braintree Pro & 3.0 Bug Fixes, iSenseLabs GDPR Compliance

I am on inmotion hosting and did a clean install of OC with Softaculus. I also installed the above modules. Other than that, the install is completely clean. While clicking around the admin panel, it kicked me out to the admin login page and I cannot get back in. I have uninstalled and reinstalled with Softaculus 3 times in the last day just trying to get started on this. On the last install I also installed the ClearThinking 3.0 Bug Fixes. I had the same problem on the two previous installs when the CT 3.0 bug fixes module was not installed. Also, it is not a password reset issue. I tried doing a password reset and it does not fix the issue.

Problem: When attempting to log in, the page flashes but does not give any error messages nor does it redirect me to the admin panel. I can log in as many times as I want like this and I never get an error message but also never getting past the login screen. I tried logging in 20 times and never received a message that I attempted too many log ins, so I never get the "you have to wait an hour before you can log back in" message. Any help would be appreciated.




Wed Feb 24, 2021 8:08 am

Post by Johnathan » Wed Feb 24, 2021 10:08 pm

This is typically related to your session being cleared immediately, which requires you to log in again, and then it happens over and over. I *have* seen this issue with my 3.0 Bug Fixes, because there's a session clearing bugfix in there. However, if you were having this issue without that installed, then it may be a server setting. Try disabling my extension and refresh your ocMod cache in Extensions > Modifications, and see if it still happens. If you need help doing that manually, you can contact me here for support:

If you still get the same issue without my 3.0 Bug Fixes installed, then you can try increasing the session timeout limit for your server. Your session may be getting cleared immediately if your server time is set to something different than your local time, and it thinks your session is old enough to clear right away. You can increase that timeout by changing this value in the /php.ini and /admin/php.ini files:

session.gc_maxlifetime = 3600

That value is in seconds, so 3600 is 1 hour. Try something larger like 86400 (which is 1 day) and see if that helps. If not, contact your web host and ask them what that value is set to, and if they can increase it for you.

Image Image Image Image

User avatar
Global Moderator


Fri Dec 18, 2009 3:08 am

Post by sw!tch » Thu Feb 25, 2021 1:30 am

If on see my post here viewtopic.php?f=201&t=222369#p813699

Reference the bold section if it applies.

Full Stack Web Developer :: Send a PM for Custom Work.
Backup and learn how to recover before you make any changes!

Active Member


Sat Apr 28, 2012 2:32 pm
Location - USA

Post by Jah22 » Thu Feb 25, 2021 4:15 am

It does look like a time zone issue. It might be worth noting I tried setting my php.ini session.gc_maxlifetime = 90000 for both the public_html and store root files. This did not fix the issue. It appears the problem arises when the "System->Settings->Local->Time Zone" field is changed. If I leave it at UTC (+00:00) there is no problem, even with the php.ini files set to defaults. When changed to America/Los Angeles (-08:00) it doesn't matter what the php.ini files are set to, I can't log back in. Thanks for the help!



Wed Feb 24, 2021 8:08 am
Who is online

Users browsing this forum: No registered users and 7 guests