Post by barjawi » Mon Apr 05, 2021 12:13 am

Greetings,

I have a big problem with the store, it suddenly became very slow, it takes more than 18 seconds to open the site, I don’t know the reason!
I have made several attempts, for example, I deleted products from the home page and also tried to delete the slider, but there was no change in the store!
Can anyone help me? I want to know what is the thing, file, or element that delays loading the site until I delete it or treat it.

Thanks

Newbie

Posts

Joined
Mon Sep 07, 2020 8:06 pm

Post by Cue4cheap » Mon Apr 05, 2021 12:37 am

What have you tried to figure it out? Have you used any of the free products like google page speed to see what they see?

Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by barjawi » Mon Apr 05, 2021 2:20 am

Cue4cheap wrote:
Mon Apr 05, 2021 12:37 am
What have you tried to figure it out? Have you used any of the free products like google page speed to see what they see?

Mike
Hi, Mike
Yes, I tried google page speed (PageSpeed Insights) but I receive this error

(Lighthouse returned error: FAILED_DOCUMENT_REQUEST. Lighthouse could not load the page you requested reliably. Make sure you test the correct URL and that the server is responding correctly to all requests. (Details: net) :: ERR_TIMED_OUT)

By the way, this is like my store link ... please someone can help me
https://abuzersat-store.com/

Newbie

Posts

Joined
Mon Sep 07, 2020 8:06 pm

Post by Cue4cheap » Mon Apr 05, 2021 2:39 am

Check your config files for the correct settings.
Make sure both HTTP_SERVER and HTTPS_SERVER are set to https.
You are missing https://abuzersat-store.com/catalog/vie ... ery.js.map

Are you seeing anything in your error logs?
What type of plan are you on with your host? It seems pretty slow. gtmetrix.com is able to load your site but at 14+ seconds for first byte.

Mike

cue4cheap not cheap quality


Active Member

Posts

Joined
Fri Sep 20, 2013 4:45 am

Post by JNeuhoff » Mon Apr 05, 2021 10:41 pm

You got some wrong markup in your HTML:

Code: Select all

<a href="http://abuzersat-store.com/index.php?route=product/product&amp;product_id=42" title="Apple Cinema 30"" target="_self">
<img class="lazy-load" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="380" height="200" data-src="https://abuzersat-store.com/image/cache/catalog/slide/allhd-white-380x200.jpg" data-srcset="" alt="Apple Cinema 30"" />
</a>
The title="Apple Cinema 30"" in above HTML is wrong!

Anyway, your TTFB is 12 seconds, so something is wrong in your server configuration, you may have to get in touch with your webhost on this!

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by by mona » Mon Apr 05, 2021 10:58 pm

JNeuhoff wrote:
Mon Apr 05, 2021 10:41 pm
You got some wrong markup in your HTML:

Code: Select all

<a href="http://abuzersat-store.com/index.php?route=product/product&amp;product_id=42" title="Apple Cinema 30"" target="_self">
<img class="lazy-load" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" width="380" height="200" data-src="https://abuzersat-store.com/image/cache/catalog/slide/allhd-white-380x200.jpg" data-srcset="" alt="Apple Cinema 30"" />
</a>
The title="Apple Cinema 30"" in above HTML is wrong!

Anyway, your TTFB is 12 seconds, so something is wrong in your server configuration, you may have to get in touch with your webhost on this!
Just to add to the first part of JNeuhoff kind assistance - before you ask -

Code: Select all

<img class="lazy-load"
is not opencart - contact the developer of the theme / extension to resolve that issue.

FYI - Please try to post in the correct forum - this is not a BUG - which is a forum used by the developers for the purposes of Opencart

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by JNeuhoff » Mon Apr 05, 2021 11:26 pm

I think the lazy image loading is part of his web theme, but I don't think it causes the slowness of the website.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 6 guests