Page 1 of 1

Best Seller Page

Posted: Tue May 19, 2020 12:00 pm
by ihateusernames
Hi,

I recently created a best seller page in OC's Design>Layout , but when I go to the created page I get the statement 'The page you requested can not be found!'.
However, the page is shown underneath that statement?
Anyone have any idea's as to why the statement is popping up & how to stop it from happening?
Thanks...

Re: Best Seller Page

Posted: Tue May 19, 2020 1:15 pm
by cedcommerceteam
ihateusernames wrote:
Tue May 19, 2020 12:00 pm
Hi,

I recently created a best seller page in OC's Design>Layout , but when I go to the created page I get the statement 'The page you requested can not be found!'.
However, the page is shown underneath that statement?
Anyone have any idea's as to why the statement is popping up & how to stop it from happening?
Thanks...
Using OC Version 3.0.3.2

Hello there,

Hope you are doing well.

Please let us know your website details so that we can check the exact issue.

Thanks!!!

Re: Best Seller Page

Posted: Tue May 19, 2020 8:43 pm
by ihateusernames

Re: Best Seller Page

Posted: Wed May 20, 2020 6:43 pm
by paulfeakins

Re: Best Seller Page

Posted: Fri May 22, 2020 11:32 am
by ihateusernames
Thanks Paul,

That's basically how I created the page, but I still don't know why the 'OC page error statement' is been called to that page, whilst at the same time showing the page that it thinks it can't find? Sometimes the statement is at the top of the page & sometimes at the bottom.
?

Re: Best Seller Page

Posted: Fri May 22, 2020 4:51 pm
by JNeuhoff
You are using route=product/bestsellers in your URL. Is there really a file named 'catalog/controller/product/bestsellers.php' on your OpenCart server? If not, you'll get the 404 error, with another page layout for the 404 error being used here which may or may not have some modules included in it.

Re: Best Seller Page

Posted: Sat May 23, 2020 2:22 pm
by ihateusernames
Thanks Jneuhoff,

I'm not getting any 404 errors, just the OC statement. When creating the url in the design>layout you have to create the url, that's the url I originally put in that field.
Regardless of whatever I call the url, (new/random/whatever) I still get the same problem. I've also tried pointing the url to the best seller module (module/bestsellers) but again, still the same problem? Page+OC statement.
Do you know the correct way to resolve the problem?
Thanks.