Post by Jacqui » Sat May 23, 2020 2:57 pm

I have open cart working on the site except the orders are not showing in admin.It is linked to Secure Trading and orders placed are being processed by Secure Trading and payment is taken. As the order is not showing the site is not sending notification of order details. When you log in to admin the order is not showing at all. Can anyone advise me please.

Newbie

Posts

Joined
Fri Jan 02, 2015 5:08 pm

Post by opencartmart » Sat May 23, 2020 3:18 pm

Jacqui wrote:
Sat May 23, 2020 2:57 pm
It is linked to Secure Trading and orders placed are being processed by Secure Trading and payment is taken.
It is a payment module issue. The payment module must process the order once the payment is complete. Contact the payment module developer.

XForm - Opencart Form Builder
Xshippingpro - An advanced Shipping Module
Need Professional support? Skype: opencartmart


Active Member

Posts

Joined
Wed Oct 02, 2013 3:59 am

Post by Jacqui » Mon May 25, 2020 3:18 pm

Thank you for your reply. I am not sure quite what you mean. I was the one who set up the site and Open Cart but I am not an expert. Are you saying that this is a problem is at the Secure Trading end, although Secure Trading is processing the order should it be sending the order details back to Open Cart. Or should Open Cart be sending the order to secure trading. I am sorry that I am not understanding but I would help me to be able to start looking in the right place.
Thank you.

Newbie

Posts

Joined
Fri Jan 02, 2015 5:08 pm

Post by letxobnav » Mon May 25, 2020 3:37 pm

I see "secure trading" payment gateway uses ipn, your orders are not still in status 0, i.e. "missing" in OC language?

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by Jacqui » Mon May 25, 2020 8:17 pm

Is this something I should ask Secure trading about because I am out of my depth. I am not sure if I should be looking in the settings of Open Cart or Secure Trading for the answer. Open Cart is not recording any orders at all.

Newbie

Posts

Joined
Fri Jan 02, 2015 5:08 pm

Post by letxobnav » Mon May 25, 2020 9:57 pm

did you check the order list with status "missing orders"?

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by Jacqui » Tue May 26, 2020 2:10 pm

Sorry for the delay. There are 5 orders in the missing status. Can you tell me what I should do to get these to show in the orders and why they are going missing in the first place. I believe that they should send an email to inform the client that an order has been placed.

Newbie

Posts

Joined
Fri Jan 02, 2015 5:08 pm

Post by sw!tch » Tue May 26, 2020 2:37 pm

Regardless of the payment API, orders go to missing status every time a customer reaches the confirm section on checkout.

It's the payment API that's responsible for updating that status to processing or any other required status. If legit orders in which you received payment for are showing missing, then you need to debug the payment API or contact the extension developer to see why.

Backup and [ learn how to recover ] before you make any changes.


Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm

Post by letxobnav » Tue May 26, 2020 3:45 pm

A new order with status 0, draft orders, missing is a stupid term, are created the moment a user confirms the payment method, it has to because external payment gateways need an order number for the callbacks.

So if your orders remain in status 0, then either
1) customers do not complete their payments.
2) you have not setup the ipn function in your secure trading account correctly
3) your site blocks the ipn callback requests from secure trading

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by Jacqui » Tue May 26, 2020 4:08 pm

Thank you all so much for your help. I now know where to go to sort the problem and I hope I will be able to get it working. Without you all I would not have able to know if I had set up something wrong in the Open Cart or in Secure Trading.
Thank you again

Newbie

Posts

Joined
Fri Jan 02, 2015 5:08 pm
Who is online

Users browsing this forum: No registered users and 24 guests