Post by Mike_Shop » Thu Aug 13, 2020 2:43 pm

Hello guys,
I am new here and I am getting desperate.
I have made quite a few sites in my life. I am not a pro but I have installed lots of Joomla and wordpress sites.
I need to install a web-shop and I was suggested to go with Opencart. - www.vlahopol.com

I have installed an Opencart which was almost ready to go live but i have decided to move it from a subdomain to a new domain.
From here all things started to go crazy.

I started to get many errors even tough it was going fine for a while..
Than i decided since is not live yet and I don't have to many products i can install a fresh Opencart via Softaculos.

it has been the 4th times in a week already since I have a new fresh Opencart in which the email does not work.
It is fresh. no module, no nothing. When I install it in the first place (in the subdomain) it was working just fine.
I did the same settings.

Now the CMS is up but i cannot start to populate it since I don't know IF email will run.

I tried for many hours in all possible ways..
i tryed with MAil and I tries with SMTP
I tried with -f and I tried with different port 25 and 465
my email is working fine it is a Gsuite from google with my "nameserver" vlahopol.com - email is working .


what do you suggest ?
I am thinking to try it one more time with OpenCart 2

Thank you for your support,
Kind regards,
Mike


User avatar
New member

Posts

Joined
Tue Aug 11, 2020 2:20 am

Post by grgr » Thu Aug 13, 2020 4:45 pm

I've had a very similar sounding issue in the past (gmail). Out of curiousity, try changing the store email address to non gmail ones and use Mail not SMTP.

If that somehow works then maybe need to use phpmailer.

It was acutally a google issue which could not be resolved, eventualy gave up and used phpMailer.

-
Image Image Image Image
VIEW ALL EXTENSIONS * EXTENSION SUPPORT * WEBSITE * CUSTOM REQUESTS


User avatar
Active Member

Posts

Joined
Mon Mar 28, 2011 4:08 pm
Location - UK

Post by letxobnav » Thu Aug 13, 2020 5:20 pm

the email does not work
What does that mean?
You receive an online error message?
You do not receive any mail?

You checked your error logs?
What is your mail server hostname?

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by by mona » Thu Aug 13, 2020 7:08 pm

try this, without the space and without the hyphen :

viewtopic.php?f=190&t=213862&p=764872

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by Mike_Shop » Thu Aug 13, 2020 8:09 pm

grgr wrote:
Thu Aug 13, 2020 4:45 pm
I've had a very similar sounding issue in the past (gmail). Out of curiousity, try changing the store email address to non gmail ones and use Mail not SMTP.

If that somehow works then maybe need to use phpmailer.

It was acutally a google issue which could not be resolved, eventualy gave up and used phpMailer.
I have my own email adresss - shop @ vlahopol . com

I tried 3 different email, too - all on vlahopol . com server
They did not work. they are hosted on Gmail / Gsuite server.


" then maybe need to use phpmailer. " - you mean to move my email server to a different hosting ? or just use a totally different mail ?

Thanks for you answer

Thank you for your support,
Kind regards,
Mike


User avatar
New member

Posts

Joined
Tue Aug 11, 2020 2:20 am

Post by Mike_Shop » Thu Aug 13, 2020 8:14 pm

letxobnav wrote:
Thu Aug 13, 2020 5:20 pm
the email does not work
What does that mean?
You receive an online error message?
You do not receive any mail?

You checked your error logs?
What is your mail server hostname?

You receive an online error message? - No i get no errors on the front end of the shop - in fact it says nothing.. it reacts like the mail was sent .
You do not receive any mail? - I don't receive any errors in the front end of the shop. In one instance I had some errors that were logs on the back end of the Open cart just few repeating and later on I have discovered that on the FTP public_html error_log.php i had a long list of errors .. Again all this with a fresh install.

You checked your error logs? - I just described a bit earlier.

What is your mail server hostname? - domain is vlahopool . com - mail server is on Gsuite / google

Thank you so much for you time

Thank you for your support,
Kind regards,
Mike


User avatar
New member

Posts

Joined
Tue Aug 11, 2020 2:20 am

Post by letxobnav » Thu Aug 13, 2020 9:09 pm

You receive an online error message? - No i get no errors on the front end of the shop - in fact it says nothing.. it reacts like the mail was sent .
that is using php mail, smtp or both?
You do not receive any mail? - I don't receive any errors in the front end of the shop. In one instance I had some errors that were logs on the back end of the Open cart just few repeating and later on I have discovered that on the FTP public_html error_log.php i had a long list of errors .. Again all this with a fresh install.
yes, if you use php mail, your host takes care of mail delivery and logs mail messages in their mail logs, have your host check those.
OC cannot do anything about php mail as everything is host-handled, OC only sets the -f header (if present) and temporarily adjusts the sendmail_from email address in the php.ini file, that is it. OC does not even check if the php mail function executes successfuly, it just assumes it does.
In short, if your php mail works, fine, it is fast, if it doesn't, only your host can assist as it is also a black-box and if they cannot, use smtp as that has OC error handling.
You checked your error logs? - I just described a bit earlier.
Well, have your host check their mail logs and you check your php error logs and oc error logs.
What is your mail server hostname? - domain is vlahopool . com - mail server is on Gsuite / google
Ok, what is the smtp hostname you enter

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by Mike_Shop » Thu Aug 13, 2020 9:24 pm

letxobnav wrote:
Thu Aug 13, 2020 9:09 pm
You receive an online error message? - No i get no errors on the front end of the shop - in fact it says nothing.. it reacts like the mail was sent .
that is using php mail, smtp or both?
You do not receive any mail? - I don't receive any errors in the front end of the shop. In one instance I had some errors that were logs on the back end of the Open cart just few repeating and later on I have discovered that on the FTP public_html error_log.php i had a long list of errors .. Again all this with a fresh install.
yes, if you use php mail, your host takes care of mail delivery and logs mail messages in their mail logs, have your host check those.
OC cannot do anything about php mail as everything is host-handled, OC only sets the -f header (if present) and temporarily adjusts the sendmail_from email address in the php.ini file, that is it. OC does not even check if the php mail function executes successfuly, it just assumes it does.
In short, if your php mail works, fine, it is fast, if it doesn't, only your host can assist as it is also a black-box and if they cannot, use smtp as that has OC error handling.
You checked your error logs? - I just described a bit earlier.
Well, have your host check their mail logs and you check your php error logs and oc error logs.
What is your mail server hostname? - domain is vlahopool . com - mail server is on Gsuite / google
Ok, what is the smtp hostname you enter

Ok, what is the smtp hostname you enter - this is what i have tried so far on SMTP
tls://smtp.gmail.com smtp.gmail.com on ports 25 / 465 / 587

I now have the hosting company trying to do it they seem to be overwhelmed as well . :((
After I have installed this morning for teh 5th time OpenCart 2x ... After four atempts with Opencart 3x
They now put again Opencart 3x . and they still cannot do it.. At least I am now convinced it was not me that did something stupid. .. something is wrong.. maybe with Open cart maibe with mai Gmail / Gsuite / accounts.. I have no idea. :((

Thank you for your support,
Kind regards,
Mike


User avatar
New member

Posts

Joined
Tue Aug 11, 2020 2:20 am

Post by grgr » Thu Aug 13, 2020 9:34 pm

Mike_Shop wrote:
Thu Aug 13, 2020 8:09 pm

I have my own email adresss - shop @ vlahopol . com

I tried 3 different email, too - all on vlahopol . com server
They did not work. they are hosted on Gmail / Gsuite server.


" then maybe need to use phpmailer. " - you mean to move my email server to a different hosting ? or just use a totally different mail ?

Thanks for you answer
No, there are some phpMailer extensions for opencart.

Your circumstance could be completely different from mine and it sounds absurd also, but if gmail/google was involed then the mail would not work. Went round in circles for days. SMTP would not work for the gmail account and the mail just never arrived if using the mail function, though appeared to be getting sent.
Only thing that got the mail flowing was by using phpMailer for Opencart and it took a while to get that to work also.
Never had a problem with any other domains or emails, it has only ever been that one specific domain name that was the problem and the problem stemmed from google/gsuite and google had no answer for it either.

When I said try a different email address, I mean a totally not gmail address. If you don't have an email address handy from a different domain unconnected to google, then sign up for a hotmail account or something.

Unlikey to be your problem, but for the few seconds required to change the email address, it removes it from the equation.

-
Image Image Image Image
VIEW ALL EXTENSIONS * EXTENSION SUPPORT * WEBSITE * CUSTOM REQUESTS


User avatar
Active Member

Posts

Joined
Mon Mar 28, 2011 4:08 pm
Location - UK

Post by letxobnav » Thu Aug 13, 2020 10:30 pm

tls://smtp.gmail.com on port 587 should work if you have turned "use less secure app access" on in your google account.
Google turns that off if not used and that will give you authentication problems.
In any event, if smtp mail cannot be send, OC will trigger an exception which will show as a very ugly json alert.

Also make sure the userid@hostname = you store email address from which you send mail or google will flag those emails as potentially spam as it cannot verify that the mail is from the account you are using.

Crystal Light Centrum Taiwan
Extensions: MailQueue | SUKHR | VBoces

“Data security is paramount at [...], and we are committed to protecting the privacy of anyone who is associated with our [...]. We’ve made a lot of improvements and will continue to make them.”
When you know your life savings are gone.


User avatar
Expert Member

Posts

Joined
Fri Aug 18, 2017 4:35 pm
Location - Taiwan

Post by Mike_Shop » Thu Aug 13, 2020 10:58 pm

letxobnav wrote:
Thu Aug 13, 2020 10:30 pm
tls://smtp.gmail.com on port 587 should work if you have turned "use less secure app access" on in your google account.
Google turns that off if not used and that will give you authentication problems.
In any event, if smtp mail cannot be send, OC will trigger an exception which will show as a very ugly json alert.

Also make sure the userid@hostname = you store email address from which you send mail or google will flag those emails as potentially spam as it cannot verify that the mail is from the account you are using.

Update,

SO, I took me 4 days to get around this and the guys at my hosting company took time to investigate and YES it is true it was not their "obligation" but they were kind enough.
YES, i have gone to Gmail setting in the admin panel and turned ON the "use less secure app access" on the google account.

now it works.
I hope with no future problems. like spam filters blocking my mail address...

I would like to thank you guys for jumping on so support and help
very much appreciated.


- A little offtopic - is it safer to go with the standard theme form Opencart or just buy a decent theme ?
- Are they safe?

are any of these any good ?

http://mooboo4.demo.towerthemes.com/
http://demo.towerthemes.com/tt_ventur/
http://ventur2.demo.towerthemes.com/
http://ventur8.demo.towerthemes.com/
http://demo.towerthemes.com/tt_ventur/i ... ry&path=59
http://raavin2.demo.towerthemes.com/
http://t902.demo.towerthemes.com/
http://t905.demo.towerthemes.com/
http://demo.towerthemes.com/tt_ravado/
http://basel.openthemer.com/accessories/

Also, I can give back to the community as I own a recording studio, i can record professional voice overs for Opencast Tutorials IF it helps..
If anyone interested - let me know - I will do it for free in my spare time.

Thank you for your support,
Kind regards,
Mike


User avatar
New member

Posts

Joined
Tue Aug 11, 2020 2:20 am

Post by sw!tch » Fri Aug 14, 2020 3:26 am

Mike_Shop wrote:
Thu Aug 13, 2020 10:58 pm

- A little offtopic - is it safer to go with the standard theme form Opencart or just buy a decent theme ?
- Are they safe?

are any of these any good ?
Read here for some suggestion viewtopic.php?t=157098 , otherwise just hire a CSS guru and modify the default template.

Please update your post to solved and open a new thread for other issues.

Full Stack Web Developer :: Send a PM for Custom Work.
Backup and learn how to recover before you make any changes!


Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm
Location - USA

Post by Mike_Shop » Fri Aug 14, 2020 3:55 am

sw!tch wrote:
Fri Aug 14, 2020 3:26 am
Mike_Shop wrote:
Thu Aug 13, 2020 10:58 pm

- A little offtopic - is it safer to go with the standard theme form Opencart or just buy a decent theme ?
- Are they safe?

are any of these any good ?
Read here for some suggestion viewtopic.php?t=157098 , otherwise just hire a CSS guru and modify the default template.

Please update your post to solved and open a new thread for other issues.

Thank you so very much for you time and support...
How do I update the post to SOLVED, please ?!

Thank you for your support,
Kind regards,
Mike


User avatar
New member

Posts

Joined
Tue Aug 11, 2020 2:20 am

Post by sw!tch » Fri Aug 14, 2020 4:04 am

Just edit the post title and add the word [Solved] in the beginning.

Full Stack Web Developer :: Send a PM for Custom Work.
Backup and learn how to recover before you make any changes!


Active Member

Posts

Joined
Sat Apr 28, 2012 2:32 pm
Location - USA

Post by Mike_Shop » Sun Aug 16, 2020 3:16 pm

sw!tch wrote:
Fri Aug 14, 2020 4:04 am
Just edit the post title and add the word [Solved] in the beginning.
Thanks Sw!tch . Much appreciated

Thank you for your support,
Kind regards,
Mike


User avatar
New member

Posts

Joined
Tue Aug 11, 2020 2:20 am
Who is online

Users browsing this forum: No registered users and 22 guests