Post by justint24 » Fri May 14, 2021 7:58 pm

Hi,

We have OC 3.0.3.2

We have 2 payment methods -
1. Cash on delivery
Order status = pending

2. Worldpay (custom extension by Opencart.Tips https://www.opencart.com/index.php?rout ... h=worldpay)
Pending status = pending
Complete status = complete
Cancelled status = cancelled

Opencart system settings - options
Order status = pending
pending also checked in the list.

When a customer checks out using Cash on delivery it works fine but not with the worldpay extension.

Scenarios
Choose cash on delivery - customer checks out > both receive email confirmation > order sets as pending.
Choose Worldpay - customer checks out > only customer receives email, no admin email > order sets as missing order.

The worldpay module was originally sending the confirmation email before successful payment until the author made a change to send the email after payment but now ALL worldpay orders are set to missing orders.

The author of the module is telling me it's a server or opencart issue and not his module. Could anyone shed more light on this or have an idea on what could be causing the missing orders.

Error log is empty.

Thanks.

Newbie

Posts

Joined
Mon Oct 27, 2014 12:49 am

Post by ADD Creative » Fri May 14, 2021 9:34 pm

Have you checked your PHP error log as well as the OpenCart one?

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by justint24 » Fri May 14, 2021 10:20 pm

Yes, checked PHP error logs. Nothing related in there. just a bunch of mysql memory issues which was resolved a week ago, problem above still persists.

Newbie

Posts

Joined
Mon Oct 27, 2014 12:49 am

Post by straightlight » Fri May 14, 2021 10:43 pm

justint24 wrote:
Fri May 14, 2021 10:20 pm
Yes, checked PHP error logs. Nothing related in there. just a bunch of mysql memory issues which was resolved a week ago, problem above still persists.
Sometimes, error logs may not be relative to the incident request you're submitting about but may still affect the same area. Therefore, please post the most recent error logs.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by justint24 » Fri May 14, 2021 11:43 pm

PHP error log attached. Like i said the memory has been upped on the server so the mysql issues will stop.
Last edited by justint24 on Sat May 15, 2021 2:29 am, edited 1 time in total.

Newbie

Posts

Joined
Mon Oct 27, 2014 12:49 am

Post by ADD Creative » Sat May 15, 2021 1:05 am

I would recommend you remove that error log and change your database password. Too much information in there.

As a test you could try going to Extensions > Events and temporally disabling the mail_order_add and then mail_order_alert event. Then put place an order. If it still goes to missing orders then the issue is likely with sending the emails, which could be caused by a modification or your theme. If not, then it's probably an issue with the payment module or incompatibility with a modification or your theme.

It also looks like you are using the Journal theme. This will make it harder to work out what the issue is and more likely to cause compatibility issue.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by straightlight » Sat May 15, 2021 1:08 am

As an alternative, since Journal is not supported on the forum, you could either contact Journal support or create a new service request in the Commercial Support section of the forum to have this issue investigated as a custom job.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by justint24 » Sat May 15, 2021 2:36 am

File deleted and password changed. Thanks for heads up.

Thank you for the suggestions. I will make some changes and do some testing. Will post back in a few days with any findings.

Newbie

Posts

Joined
Mon Oct 27, 2014 12:49 am

Post by paulfeakins » Mon May 17, 2021 6:39 pm


For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by justint24 » Mon May 17, 2021 10:02 pm

Hi,

So i tried Extensions > Events and temporally disabling the mail_order_add and then mail_order_alert event. = Still missing orders.

I switched from SMTP to Mail = Still missing orders.

It was all working fine until the author of the Worldpay module made a change to send email confirmations after payment instead of when clicking 'Confirm Order'.

Just not sure what else it could be. We have another website on OC with journal but not worldpay and that works fine.

Newbie

Posts

Joined
Mon Oct 27, 2014 12:49 am

Post by ADD Creative » Wed May 19, 2021 4:44 pm

Would seem an issue with the payment module in someway.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by DannyM » Thu May 20, 2021 3:59 pm

ADD Creative wrote:
Wed May 19, 2021 4:44 pm
Would seem an issue with the payment module in someway.
No, it's not :)

✯ Professional OpenCart Support [UK-based] ✯
https://opencart.tipshttps://opencart.com.plhttps://facebook.com/opencarttips ✯ Live-chat: http://pixly.me/livechat


User avatar
Active Member

Posts

Joined
Sun Jan 03, 2010 4:23 am
Location - Bournemouth, UK

Post by ADD Creative » Thu May 20, 2021 4:38 pm

DannyM wrote:
Thu May 20, 2021 3:59 pm
No, it's not :)
Care to explain?

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by khnaz35 » Thu May 20, 2021 6:06 pm

Have you ask the worldpay extension developer about this issue?
looks like call back issue after the payment is made.

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by DannyM » Thu May 20, 2021 6:21 pm

1. Server response is too slow to get the data

2. database issues
DB\MySQLi::__construct(): Couldn't fetch mysqli in /public_html/system/library/db/mysqli.php on line 10
PHP Warning: mysqli::__construct(): (HY000/1045): Access denied for user 'xxxx'@'localhost' (using password: YES)

3. Payment Response password incorrect

4. Payment Response URL incorrect

etc.

✯ Professional OpenCart Support [UK-based] ✯
https://opencart.tipshttps://opencart.com.plhttps://facebook.com/opencarttips ✯ Live-chat: http://pixly.me/livechat


User avatar
Active Member

Posts

Joined
Sun Jan 03, 2010 4:23 am
Location - Bournemouth, UK

Post by straightlight » Thu May 20, 2021 8:01 pm

DannyM wrote:
Thu May 20, 2021 6:21 pm
1. Server response is too slow to get the data

2. database issues
DB\MySQLi::__construct(): Couldn't fetch mysqli in /public_html/system/library/db/mysqli.php on line 10
PHP Warning: mysqli::__construct(): (HY000/1045): Access denied for user 'xxxx'@'localhost' (using password: YES)

3. Payment Response password incorrect

4. Payment Response URL incorrect

etc.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by DannyM » Thu May 20, 2021 10:53 pm

The issue has been solved
Solution: p3 and p4 ;)

✯ Professional OpenCart Support [UK-based] ✯
https://opencart.tipshttps://opencart.com.plhttps://facebook.com/opencarttips ✯ Live-chat: http://pixly.me/livechat


User avatar
Active Member

Posts

Joined
Sun Jan 03, 2010 4:23 am
Location - Bournemouth, UK
Who is online

Users browsing this forum: No registered users and 34 guests