Post by fido-x » Sat May 01, 2010 11:31 am

The following modules have been rebuilt for OpenCart 1.4.7.
Calendar 147 Get it here.
Homepage 147 Get it here.
Locations 147 Get it here.
News 147 Get it here.

These are not merely "updates", they have been rebuilt from the ground up. Now include a "Plug 'n' Play" design. This means you no longer have to edit any core files to get them working, everything is controlled through the module.

The "Latest Products", "Special Offers" and "Featured Products" modules included with the "Homepage" package are replacements for the those that are included with the standard OC 1.4.7. They work the same way, and merely add an extra position of "Homepage" to the choice of positions.

These modules are for use with OpenCart 1.4.7 and are NOT compatible with earlier versions of OpenCart.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by phuungu » Mon May 03, 2010 11:07 am

thank you, it's great!! O0 i wish i can be like u, upload some constribution too. maybe some beautiful template from me as soon as possible.

thx 4 all :)

User avatar
Newbie

Posts

Joined
Sun Mar 07, 2010 11:56 pm

Post by OCyvon2 » Fri May 07, 2010 5:29 pm

Hi,

I downloaded the calendar and it seems to work fine. Only the language of the calendar stays in Eng.
In English is always Y-m-d but in Dutch it is d-m-Y. Where can I change this so it will support every language?

OpenCartstore
Gebruikersgids (admin handleiding)


User avatar
Active Member

Posts

Joined
Sun Jan 31, 2010 8:00 pm
Location - Zaandam, The Netherlands

Post by inspiredbyiris » Fri May 07, 2010 5:46 pm

Hi fido-x

I try to install news 147 but get this error when i insert a news
Forbidden

You don't have permission to access /shop/admin/index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Can you help me to solve this problem?

Thank you!


Posts

Joined
Fri May 07, 2010 5:38 pm

Post by OCyvon2 » Fri May 07, 2010 6:16 pm

You have to activate your permissions via admin - usergroups

And did some changes in the codes to make it work for me.

OpenCartstore
Gebruikersgids (admin handleiding)


User avatar
Active Member

Posts

Joined
Sun Jan 31, 2010 8:00 pm
Location - Zaandam, The Netherlands

Post by fido-x » Fri May 07, 2010 8:00 pm

inspiredbyiris wrote:Hi fido-x

I try to install news 147 but get this error when i insert a news
Forbidden

You don't have permission to access /shop/admin/index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Can you help me to solve this problem?

Thank you!
You'll note the permissions error is on your "admin/index.php" file, that is nothing to do with the news module. Check permissions on your "admin/index.php", they should be 664.
OCyvon2 wrote:You have to activate your permissions via admin - usergroups

And did some changes in the codes to make it work for me.
It is NOT necessary to set permissions on the modules for 1.4.7, everything is controlled through the module. All you have to do is "install" the module and this automatically sets the permissions, the same as any other module.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by inspiredbyiris » Fri May 07, 2010 11:59 pm

Hi fido-x,

Thank you for your support!

I just reinstall and it works very well.

Just another question, how can i add the title and date added?

Image


Posts

Joined
Fri May 07, 2010 5:38 pm

Post by fido-x » Sat May 08, 2010 1:08 am

The column module wasn't intended to have a "title" (or headline) or a "date added", these can be found on the "Headlines" page (the main news page), which you can get it from the link you added a link in your Information module (if you added one).

However, having said that - to add a "title" (or headline) to the column module, insert the following into "catalog/view/theme/YOUR_TEMPLATE/template/module/news.tpl" at line 18:-

Code: Select all

<h4><?php echo $news_story['title']; ?></h4>
And for the "date added", insert the following at what is now line 20 (same file):-

Code: Select all

<p><?php echo $text_date_added; ?> <?php echo $news_story['date_added']; ?></p>
You'll also have to edit the controller for the module (catalog/controller/module/news.php), by inserting the following at line 7:-

Code: Select all

$this->load->language('information/news');
$this->data['text_date_added'] = $this->language->get('text_date_added');
Then, insert the following at (what is now) line 19:-

Code: Select all

'date_added'        => date($this->language->get('date_format_short'), strtotime($result['date_added'])),

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by OCyvon2 » Wed May 12, 2010 6:54 pm

Hi Fido-x,

Is there a way to change the dates into another language?

OpenCartstore
Gebruikersgids (admin handleiding)


User avatar
Active Member

Posts

Joined
Sun Jan 31, 2010 8:00 pm
Location - Zaandam, The Netherlands

Post by fido-x » Wed May 12, 2010 9:35 pm

The calendar uses the PHP date() function. I don't know if the date returned by this function can be set to be in a language other than English. If it can, there would be a setting somewhere in the php.ini file. You might have to search http://php.net to find an answer.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by linuxaisle » Fri May 21, 2010 10:29 am

I get a 404 error when I click edit in the module manager
mydomain/myadmin/index.php?route=module/news

my admin directory is no longer "/admin/" but I uploaded all the files correctly.

OpenCart user since 4/27/10


New member

Posts

Joined
Wed Apr 28, 2010 2:01 pm

Post by fido-x » Fri May 21, 2010 10:50 am

linuxaisle wrote:I get a 404 error when I click edit in the module manager
mydomain/myadmin/index.php?route=module/news

my admin directory is no longer "/admin/" but I uploaded all the files correctly.
If you've uploaded the files to the correct locations, you shouldn't have any problems. It would appear that you haven't uploaded the files to the correct locations.

I'm not talking out my backside here, I have tested this on my local machine by making the same change you made (ie. changing the name of the admin folder to something else), and I had no problems.

It is not sufficient to just change the name of the admin directory, you also need to reflect the changed name in the admin configuration file (admin/config.php).

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by linuxaisle » Fri May 21, 2010 11:02 am

I have changed the config.php and everything has been working perfectly.
All I've done so far is upload the files and click install. It installs but when I click edit, I get the 404 error. I've double checked all the files are on my server where they should be.

OpenCart user since 4/27/10


New member

Posts

Joined
Wed Apr 28, 2010 2:01 pm

Post by fido-x » Fri May 21, 2010 11:33 am

I can't re-create your error. In my local copy, after changing the name of the admin folder, I uninstalled the "Latest News" module, then re-installed it, clicked edit and had no problems. The only thing I can think of, is that you didn't upload the files correctly. I'm sorry this isn't much help, but that's all I can suggest since I can't duplicate (or re-create) the problem you're having.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by linuxaisle » Fri May 21, 2010 12:19 pm

Is it possible that a constant is being defined twice somewhere? I've had this problem before on my host. The script fails when a constant is being defined for a second time and either nothing happens if it's doing something behind-the-scenes, or it gives a 404 if it's generating a page.
I'll work on this for a while and let you know if I find anything useful. Any help is appreciated. This mod looks great.

I would just switch hosts but they already have my money :(

OpenCart user since 4/27/10


New member

Posts

Joined
Wed Apr 28, 2010 2:01 pm

Post by linuxaisle » Fri May 21, 2010 12:27 pm

OK, it was faster than I thought...

I commented out line 8 in /admin/controller/module/news.php
// $this->load->language('module/news');
and it loads now.

Had to comment out line 20 and 32 to be able to add news and update news.

The only language I see missing are the page titles and text_success upon adding news.

THANK YOU for the module!! I love it ;D
I will use it to develop an article manager and release it for free ;) I don't think it's right for devs to charge for add-ons to open source software.

OpenCart user since 4/27/10


New member

Posts

Joined
Wed Apr 28, 2010 2:01 pm

Post by linuxaisle » Fri May 21, 2010 1:49 pm

One more thing, the news.tpl does not detect whether it is on the home page or on the side.

OpenCart user since 4/27/10


New member

Posts

Joined
Wed Apr 28, 2010 2:01 pm

Post by fido-x » Fri May 21, 2010 4:07 pm

linuxaisle wrote:I commented out line 8 in /admin/controller/module/news.php
// $this->load->language('module/news');
and it loads now.

Had to comment out line 20 and 32 to be able to add news and update news.
If commenting out references to the language file fixes your problem, then there is something wrong with how you've got your system set up that goes a lot deeper than the news module.
... I don't think it's right for devs to charge for add-ons to open source software.
Since this is a free module, I have no idea what you're talking about.
One more thing, the news.tpl does not detect whether it is on the home page or on the side.
Yes it does! Did you follow the instructions in the readme file on how to get it to display on the home page?

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by linuxaisle » Fri May 21, 2010 4:18 pm

fido-x wrote:If commenting out references to the language file fixes your problem, then there is something wrong with how you've got your system set up that goes a lot deeper than the news module.
No doubt about that. I'll be looking for a new server as soon as I start making some money.
Since this is a free module, I have no idea what you're talking about.
Right, I wasn't talking about your module, just in general. Thank you!
Yes it does! Did you follow the instructions in the readme file on how to get it to display on the home page?
Yes, I followed the instructions. isset($homepage) was not returning true for some reason. I had no problem fixing it, so if I'm the only one then don't worry about it.

Peace
Check it out :D Best Linux printers

OpenCart user since 4/27/10


New member

Posts

Joined
Wed Apr 28, 2010 2:01 pm

Post by fido-x » Fri May 21, 2010 4:34 pm

linuxaisle wrote:Yes, I followed the instructions. isset($homepage) was not returning true for some reason. I had no problem fixing it, so if I'm the only one then don't worry about it.
If isset($homepage) is not returning a value, your problems lie outside the news module. You've put something in the wrong place. And yes, you are the only one complaining about it. Perhaps the problem lies in the fact that you are using a customised layout and this is most likely the cause of ALL your problems. The standard template uses a 3 column layout, you only have 2.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia
Who is online

Users browsing this forum: No registered users and 4 guests