Post by alanprotrade » Thu Jul 24, 2008 6:08 pm

Hi all,

Firstly love opencart have toyed around with loads of other carts and love the ease of use of this one so kudos to the techies!

Now the problem, basically I have spent the last two days doing a trade website for my employer www.alanprotrade.co.uk (which I am still working on)

However I cannot access the admin backend I get the following error message:

Error: Maximum number of forwards has been exceeded!

I am in a right state at the moment as my boss is screwing that it is not finished, please for the love of god someone help me!!!!! :'(
Last edited by alanprotrade on Thu Jul 24, 2008 7:22 pm, edited 1 time in total.

Newbie

Posts

Joined
Thu Jul 24, 2008 6:05 pm

Post by alanprotrade » Thu Jul 24, 2008 9:26 pm

Anyone? ???

Newbie

Posts

Joined
Thu Jul 24, 2008 6:05 pm

Post by JNeuhoff » Thu Jul 24, 2008 10:17 pm

Any error message in your server logs? Are you using a shared web hosting account, or a dedicated server machine?
What's in your /config.php and your /admin/config.php files?

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by alanprotrade » Thu Jul 24, 2008 10:28 pm

Using shared hosting to be honest everythings been fine until this morning

Newbie

Posts

Joined
Thu Jul 24, 2008 6:05 pm

Post by alanprotrade » Thu Jul 24, 2008 10:35 pm

JNeuhoff wrote: Any error message in your server logs? Are you using a shared web hosting account, or a dedicated server machine?
What's in your /config.php and your /admin/config.php files?
config.php



admin/config.php





Any help appreciated.
;)

Newbie

Posts

Joined
Thu Jul 24, 2008 6:05 pm

Post by JNeuhoff » Thu Jul 24, 2008 10:54 pm

Hmm, your config.php files like fine.

Any error messages in your server log files?

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by alanprotrade » Thu Jul 24, 2008 10:59 pm

JNeuhoff wrote: Hmm, your config.php files like fine.

Any error messages in your server log files?
I am using plesk, forgive me for being an idiot how would i access these?
And thanks for your guidance btw ;D

Newbie

Posts

Joined
Thu Jul 24, 2008 6:05 pm

Post by alanprotrade » Fri Jul 25, 2008 4:27 pm

Anyone? :'(

Newbie

Posts

Joined
Thu Jul 24, 2008 6:05 pm

Post by david.gilbert » Fri Jul 25, 2008 4:54 pm

if you can PM me your plesk login details I'll have a look for you. It would be an idea to change your password prior to PMing me and then change it back. Not that I would do anything later but it's a security precaution I like to take..

-Dave

Professional Website Services - http://www.davidmgilbert.com/


User avatar
Active Member

Posts

Joined
Sun Jan 06, 2008 5:02 pm
Location - Mount Compass, South Australia

Post by JNeuhoff » Fri Jul 25, 2008 5:22 pm

The error message results from the /library/application/controller.php, in function dispatch, which is called by the /admin/index.php. For some reason the admin's default action (/admin/controller/home.php in function index) has some problems.

As regards error logs: After login into Plesk, click on Server (on the left side), then on the Log Settings icon. From there, make sure your error logs are enabled. Then click on General Desktop on the left, then on the Manage Files On Domain icon, which leads to your domain specific file manager, where you should find your error log file.
Last edited by JNeuhoff on Fri Jul 25, 2008 5:24 pm, edited 1 time in total.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by alanprotrade » Fri Jul 25, 2008 5:41 pm

JNeuhoff wrote: The error message results from the /library/application/controller.php, in function dispatch, which is called by the /admin/index.php. For some reason the admin's default action (/admin/controller/home.php in function index) has some problems.

As regards error logs: After login into Plesk, click on Server (on the left side), then on the Log Settings icon. From there, make sure your error logs are enabled. Then click on General Desktop on the left, then on the Manage Files On Domain icon, which leads to your domain specific file manager, where you should find your error log file.

Please see:

http://www.alanprotrade.co.uk/error.txt

For error log file/.

Newbie

Posts

Joined
Thu Jul 24, 2008 6:05 pm

Post by JNeuhoff » Fri Jul 25, 2008 6:02 pm

The only relevant error message I could find was this one:

Code: Select all

[Tue Jul 22 12:31:44 2008] [error] [client 84.252.237.84] PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 11496 bytes) in /var/www/vhosts/alanprotrade.co.uk/httpdocs/library/image/image.php on line 72, referer: http://www.alanprotrade.co.uk/admin/index.php?controller=image&action=insert
It suggests memory allocation problems in your PHP settings.

I just tried the URL http://www.alanprotrade.co.uk/admin/ in my web browser, and rather than coming up with the expected login prompt, it produces the error message: Error: Maximum number of forwards has been exceeded!

Please retrieve your error log again, it should now contain some error messages from my failed attempt to reach the http://www.alanprotrade.co.uk/admin/ . Can you also provide the most recent entries of your access log file, too?

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by alanprotrade » Fri Jul 25, 2008 7:29 pm

JNeuhoff wrote: The only relevant error message I could find was this one:

Code: Select all

[Tue Jul 22 12:31:44 2008] [error] [client 84.252.237.84] PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 11496 bytes) in /var/www/vhosts/alanprotrade.co.uk/httpdocs/library/image/image.php on line 72, referer: http://www.alanprotrade.co.uk/admin/index.php?controller=image&action=insert
It suggests memory allocation problems in your PHP settings.

I just tried the URL http://www.alanprotrade.co.uk/admin/ in my web browser, and rather than coming up with the expected login prompt, it produces the error message: Error: Maximum number of forwards has been exceeded!

Please retrieve your error log again, it should now contain some error messages from my failed attempt to reach the http://www.alanprotrade.co.uk/admin/ . Can you also provide the most recent entries of your access log file, too?
Please see most recent files:

www.alanprotrade.co.uk/accesslog.txt
www.alanprotrade.co.uk/error.txt

Cheers

Newbie

Posts

Joined
Thu Jul 24, 2008 6:05 pm

Post by fido-x » Fri Jul 25, 2008 8:15 pm

The following lines in your log file:-

Code: Select all

[Fri Jul 25 02:10:06 2008] [warn] RSA server certificate CommonName (CN) `www.alanprotrade.co.uk' does NOT match server name!? 
[Fri Jul 25 02:10:09 2008] [warn] RSA server certificate CommonName (CN) `www.alanprotrade.co.uk' does NOT match server name!? 
suggest a mismatch between your server security certificate and it's corresponding key. This is a cause of the "Maximum number of forwards has been exceeded" error message - I had the same problem myself after fiddling about with certificates. Make sure that the paths to the certificate and key are correct in your web server's SSL configuration file, or create/buy a new certificate with a matching key.

Regards, Fido-X.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by JNeuhoff » Fri Jul 25, 2008 8:28 pm

OK, now were are getting there.

The relevant message from the error log is:

Code: Select all

PHP Notice: Undefined index: price in /var/www/vhosts/alanprotrade.co.uk/httpdocs/catalog/template/default/content/category.tpl on line 49, referer: http://www.alanprotrade.co.uk/
It should have used a template file from the directory /var/www/vhosts/alanprotrade.co.uk/httpdocs/admin/

Where are your '.htaccess' files? There should be only one located at /var/www/vhosts/alanprotrade.co.uk/httpdocs/.htaccess !

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by alanprotrade » Fri Jul 25, 2008 9:19 pm

JNeuhoff wrote: OK, now were are getting there.

The relevant message from the error log is:

Code: Select all

PHP Notice: Undefined index: price in /var/www/vhosts/alanprotrade.co.uk/httpdocs/catalog/template/default/content/category.tpl on line 49, referer: http://www.alanprotrade.co.uk/
It should have used a template file from the directory /var/www/vhosts/alanprotrade.co.uk/httpdocs/admin/

Where are your '.htaccess' files? There should be only one located at /var/www/vhosts/alanprotrade.co.uk/httpdocs/.htaccess !
I was missing the htaccess file have now uploaded nothing new though still the same error

Newbie

Posts

Joined
Thu Jul 24, 2008 6:05 pm

Post by JNeuhoff » Fri Jul 25, 2008 10:01 pm

fido-x wrote: The following lines in your log file:-

Code: Select all

[Fri Jul 25 02:10:06 2008] [warn] RSA server certificate CommonName (CN) `www.alanprotrade.co.uk' does NOT match server name!? 
[Fri Jul 25 02:10:09 2008] [warn] RSA server certificate CommonName (CN) `www.alanprotrade.co.uk' does NOT match server name!? 
suggest a mismatch between your server security certificate and it's corresponding key. This is a cause of the "Maximum number of forwards has been exceeded" error message - I had the same problem myself after fiddling about with certificates. Make sure that the paths to the certificate and key are correct in your web server's SSL configuration file, or create/buy a new certificate with a matching key.

Regards, Fido-X.
Fido-X, He doesn't use the HTTPS protocol, how can that cause this problem?

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by fido-x » Fri Jul 25, 2008 10:42 pm

The issue of whether or not he is using HTTPS on his OpenCart installation is independent of the server setting in the Apache server configuration file.

If the security certificate and key do not match the server will have problems - it has nothing to do with OpenCart or it's configuration.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by JNeuhoff » Sat Jul 26, 2008 12:25 am

fido-x wrote: The issue of whether or not he is using HTTPS on his OpenCart installation is independent of the server setting in the Apache server configuration file.

If the security certificate and key do not match the server will have problems - it has nothing to do with OpenCart or it's configuration.
To alanprotrade: In that case you should get in touch with the customer support, I assume your webhosting service is from http://www.smudge-it.co.uk, isn't it?

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by alanprotrade » Thu Jul 31, 2008 5:25 pm

Hi yes my hosting is the smudge-it.

I have reinstalled and done everything again completely have no problems now. It was the SSL that was the problem.

Pig to do it all again however, I am learning more about OC by reinstalling it and it just confirms the software is the nuts, kudos to the dev team you guys rock!

Newbie

Posts

Joined
Thu Jul 24, 2008 6:05 pm
Who is online

Users browsing this forum: No registered users and 3 guests