Post by figge88 » Wed Jun 10, 2020 12:16 pm

Hi!
I'm trying to update my "Terms and Conditions" under Catalog/Information, but it seems as if the same problem will occur on all information pages.
When adding a description it all goes well if the total amount of characters is less than 598. So if I add 597 characters and hit "Save" it works fine.
But as soon as I exceed 597 characters in the description and I press "Save" I get this error message:

Code: Select all

Notice: Undefined index: description in /home/XXX/public_html/admin/view/template/catalog/information_form.tpl on line 55
And this is shown inside the text box for "Description" and all my text is gone.
Below the text box this mesage shows;
"Description must be more than 3 characters!".
In the very top of the browser page an other error message show:

Code: Select all

Notice: Undefined index: description in /home/XXX/public_html/admin/controller/catalog/information.php on line 447
Any suggestions on what to do is much appreciated.
Running version 2.0.3.1 and default template.
A couple of years have gone by since I actually did anything with my website, so memory isn't that good, but I think I upgraded from version 1.5.x.x to this 2.0.3.1 version and I believe I haven't tried changing any of these information pages since. Perhaps something went bad with the upgrade?

Regards
Fredrik

New member

Posts

Joined
Tue Apr 10, 2012 12:16 am

Post by opencartmart » Wed Jun 10, 2020 3:30 pm

Do you have several languages in your store?
You can try increasing PHP parameter `post_max_size`.

XForm - Opencart Form Builder
Xshippingpro - An advanced Shipping Module
Need Professional support? Skype: opencartmart


Active Member

Posts

Joined
Wed Oct 02, 2013 3:59 am

Post by paulfeakins » Wed Jun 10, 2020 5:45 pm

opencartmart wrote:
Wed Jun 10, 2020 3:30 pm
You can try increasing PHP parameter `post_max_size`.
Could be this, or max_input_vars, or mod_security - ask your web host.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by figge88 » Sun Jun 21, 2020 8:59 pm

opencartmart wrote:
Wed Jun 10, 2020 3:30 pm
Do you have several languages in your store?
Yes I have, but I've tried disable languages so I only have one active, but with no change of the error messages.
paulfeakins wrote:
Wed Jun 10, 2020 5:45 pm
opencartmart wrote:
Wed Jun 10, 2020 3:30 pm
You can try increasing PHP parameter `post_max_size`.
Could be this, or max_input_vars, or mod_security - ask your web host.
So when you say I should ask my web host, these settings aren´t something I can change myself? Neither in phpMyAdmin or in a file from Opencart?

New member

Posts

Joined
Tue Apr 10, 2012 12:16 am

Post by straightlight » Sun Jun 21, 2020 9:15 pm

figge88 wrote:
Sun Jun 21, 2020 8:59 pm
opencartmart wrote:
Wed Jun 10, 2020 3:30 pm
Do you have several languages in your store?
Yes I have, but I've tried disable languages so I only have one active, but with no change of the error messages.
paulfeakins wrote:
Wed Jun 10, 2020 5:45 pm
opencartmart wrote:
Wed Jun 10, 2020 3:30 pm
You can try increasing PHP parameter `post_max_size`.
Could be this, or max_input_vars, or mod_security - ask your web host.
So when you say I should ask my web host, these settings aren´t something I can change myself? Neither in phpMyAdmin or in a file from Opencart?
Those are host settings instantiated, either, by your php.ini or .user.ini file in your Opencart root folder or from the admin folder on your file server.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 40 guests