Post by dedoboss » Fri Sep 18, 2020 12:12 am

Hi
using OC 2.0.3.1 with journal 2 theme

I added 2 custom fields (text type)
the problem is: data are not saved at all...

please help me ;D

ciao and thank you very much

New member

Posts

Joined
Fri Sep 30, 2011 3:26 pm

Post by IP_CAM » Fri Sep 18, 2020 1:18 am


I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'400 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by dedoboss » Mon Sep 28, 2020 8:23 pm

hello.... nobody can help me with this?

New member

Posts

Joined
Fri Sep 30, 2011 3:26 pm

Post by ADD Creative » Tue Sep 29, 2020 7:22 am

Do you see any errors in your errors PHP or OpenCart error logs that could be related? Have you tried with just the default theme on a clean install? Where are you adding the custom field and with what settings and which form fails to save it?

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by dedoboss » Wed Sep 30, 2020 5:52 pm

ADD Creative wrote:
Tue Sep 29, 2020 7:22 am
Do you see any errors in your errors PHP or OpenCart error logs that could be related? Have you tried with just the default theme on a clean install? Where are you adding the custom field and with what settings and which form fails to save it?
Thanks for your reply!
I find this in opencart error log:
2020-09-30 9:40:58 - PHP Notice: unserialize(): Error at offset 27 of 32 bytes in /home/fgbfixpo/public_html/vqmod/vqcache/vq2-admin_model_sale_customer.php on line 306
2020-09-30 9:41:01 - PHP Notice: unserialize(): Error at offset 32 of 32 bytes in /home/fgbfixpo/public_html/vqmod/vqcache/vq2-admin_model_sale_customer.php on line 306
2020-09-30 9:41:09 - PHP Notice: unserialize(): Error at offset 32 of 32 bytes in /home/fgbfixpo/public_html/vqmod/vqcache/vq2-admin_model_sale_customer.php on line 306
2020-09-30 9:42:43 - PHP Notice: unserialize(): Error at offset 27 of 32 bytes in /home/fgbfixpo/public_html/vqmod/vqcache/vq2-admin_model_sale_customer.php on line 306
2020-09-30 9:42:44 - PHP Notice: unserialize(): Error at offset 27 of 32 bytes in /home/fgbfixpo/public_html/vqmod/vqcache/vq2-admin_model_sale_customer.php on line 306
2020-09-30 9:42:44 - PHP Notice: unserialize(): Error at offset 32 of 32 bytes in /home/fgbfixpo/public_html/vqmod/vqcache/vq2-admin_model_sale_customer.php on line 306
2020-09-30 9:42:45 - PHP Notice: unserialize(): Error at offset 32 of 32 bytes in /home/fgbfixpo/public_html/vqmod/vqcache/vq2-admin_model_sale_customer.php on line 306
2020-09-30 9:42:49 - PHP Notice: unserialize(): Error at offset 32 of 32 bytes in /home/fgbfixpo/public_html/vqmod/vqcache/vq2-admin_model_sale_customer.php on line 306


The problem is in the registration form and in customer/modify admin tab too.

New member

Posts

Joined
Fri Sep 30, 2011 3:26 pm

Post by ADD Creative » Wed Sep 30, 2020 6:06 pm

Those errors don't look to be related. Have you tried with just the default theme? What settings are you using for the custom fields?

Have you checked the custom_field column in the oc_customer table in the database to see if the issue is saving or displaying?

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by dedoboss » Wed Sep 30, 2020 6:21 pm

ADD Creative wrote:
Wed Sep 30, 2020 6:06 pm
Those errors don't look to be related. Have you tried with just the default theme? What settings are you using for the custom fields?

Have you checked the custom_field column in the oc_customer table in the database to see if the issue is saving or displaying?
Ciao
in the custom_field column in oc_customer table I can find: "a:0:{}"

Settings for my 2 custom fields are:
Location: Address
Type: Text
Value: empty
Customer Group: all
Required: none
status Enabled
Sort order 10/11

Can't chesk now with the default theme because it is a live website... could check tonight, maybe!
But I'm not sure it could be a theme problem... it happen in the admin section too...

thanks

New member

Posts

Joined
Fri Sep 30, 2011 3:26 pm

Post by IP_CAM » Wed Sep 30, 2020 7:04 pm

Well, OcMod + VqMod, in addition to a Journal Theme, it could not be
done much worse ...
Good Luck! :D
Ernie

I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'400 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by dedoboss » Wed Sep 30, 2020 7:29 pm

IP_CAM wrote:
Wed Sep 30, 2020 7:04 pm
Well, OcMod + VqMod, in addition to a Journal Theme, it could not be
done much worse ...
Good Luck! :D
Ernie
These are the kind of replies that I prefer! Compliments! O0

New member

Posts

Joined
Fri Sep 30, 2011 3:26 pm

Post by ADD Creative » Wed Sep 30, 2020 7:50 pm

dedoboss wrote:
Wed Sep 30, 2020 6:21 pm
Ciao
in the custom_field column in oc_customer table I can find: "a:0:{}"

Settings for my 2 custom fields are:
Location: Address
Type: Text
Value: empty
Customer Group: all
Required: none
status Enabled
Sort order 10/11

Can't chesk now with the default theme because it is a live website... could check tonight, maybe!
But I'm not sure it could be a theme problem... it happen in the admin section too...

thanks
As the location is address, you need to check the custom_field column in the oc_address table in the database. For me it looks like the flowing for custom fields with IDs 1 and 2.

Code: Select all

{"1":"Text entered in field 1","2":"Text entered in field 2"}
As it happens in the admin too, do you have any extensions that modify anything with the customer accounts or addresses?

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by dedoboss » Wed Sep 30, 2020 8:04 pm

As the location is address, you need to check the custom_field column in the oc_address table in the database. For me it looks like the flowing for custom fields with IDs 1 and 2.

Code: Select all

{"1":"Text entered in field 1","2":"Text entered in field 2"}
As it happens in the admin too, do you have any extensions that modify anything with the customer accounts or addresses?
[/quote]

Yes, I can see the values in the oc_address table!
They does not appear in admin...
And yes, we use a, extension to divide private customer/companies/foreign companies, to apply or not taxes and fees.

New member

Posts

Joined
Fri Sep 30, 2011 3:26 pm

Post by ADD Creative » Thu Oct 01, 2020 1:12 am

That would suggest that they are being saved correctly, but not being read form the database or not being displayed correctly.

You may be best making a duplicate of your site locally or on another part of your hosting and disable your extensions and theme one by one, to see if you can work out if they are causing the issue.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom
Who is online

Users browsing this forum: No registered users and 6 guests