Post by siteadvice » Tue Jan 19, 2021 1:35 am

Thanks to everyone who contributed to this thread.

I have now figured out the problem - it was caused by an invalid licence key.

An extension that I had installed on the live site was automatically disabled on the development site because the licence key didn't match the domain name.

When I uninstalled the modification, everything worked correctly.

The problem was that twig variables were being called in the product edit form, but those variables were unavailable, due to the mod being deactivated, causing the page to fail.

I had not spotted this at first - I had tried disabling all of my module extensions but this was a modification, not a module.

Hope it might help anyone else in the same situation - where possible, if your extensions requires a licence key, politely request a second licence from the publisher so that you can use it privately on your development server. Website Design with Opencart, Wordpress, Lucee and bespoke application design and development

User avatar
New member


Mon Oct 24, 2011 8:12 pm

Post by JNeuhoff » Tue Jan 19, 2021 1:47 am

Glad to hear you resolved this problem, please add the '[SOLVED]' to this forum thread title.

BTW.: You example illustrates one of many issues with Symfony-Twig: The template engine should not just silently ignore non-existing variables, it should log appropriate error messages!

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus

User avatar
Expert Member


Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 29 guests