Post by Gilmore » Thu Apr 08, 2021 1:21 pm

I keep having an intermittent problem when a customer checks out using Advanced Card with PayPal Commerce Platform OC3.x v1.1.2 The order goes thru on OC, but it doesn't process thru PayPal.

It was working perfectly for the past 10 months, but over the past 2 weeks, every now and then the sale completes on the OC side, but doesn't show up in PayPal. On the OC side it shows Complete. Also the Customer doesn't show the charge on their card. So I have to tell them that it didn't process and then send them a PayPal invoice to pay for their order.

I didn't want to update to v1.2.0 as my sales are small and my customers don need the PayPal Pay in 4 feature and there's no way to disable it.

And how to update PayPal Commerce Platform? So I just run the Installer under Extensions?

Is PayPal Commerce Platform OC3.x v1.1.4 better?

Anyone else having this problem? Has any one found a fix for this problem?

Thanks!

Gilmore


User avatar
Active Member

Posts

Joined
Thu Aug 12, 2010 7:33 am

Post by straightlight » Thu Apr 08, 2021 8:51 pm

Gilmore wrote:
Thu Apr 08, 2021 1:21 pm
I keep having an intermittent problem when a customer checks out using Advanced Card with PayPal Commerce Platform OC3.x v1.1.2 The order goes thru on OC, but it doesn't process thru PayPal.

It was working perfectly for the past 10 months, but over the past 2 weeks, every now and then the sale completes on the OC side, but doesn't show up in PayPal. On the OC side it shows Complete. Also the Customer doesn't show the charge on their card. So I have to tell them that it didn't process and then send them a PayPal invoice to pay for their order.

I didn't want to update to v1.2.0 as my sales are small and my customers don need the PayPal Pay in 4 feature and there's no way to disable it.

And how to update PayPal Commerce Platform? So I just run the Installer under Extensions?

Is PayPal Commerce Platform OC3.x v1.1.4 better?

Anyone else having this problem? Has any one found a fix for this problem?
OC precise version. Upgrade to the latest release of the extension and see the results by following the upgrade instructions offered on the Marketplace.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Gilmore » Thu Apr 08, 2021 10:36 pm

I'm running OC v3.0.3.2 PHP v7.3.27

I had upgraded to the latest, but the PayPal Pay in 4 didn't agree with my layout and was confusing for my customers. I had instant complaints about it. So I went back to the previous one. Is there a way to disable the buttons that PayPal Pay in 4 places on my site since I don't need them on PayPal Commerce v1.2.0?

Also when I ran the installer, it still showed the previous version of PayPal Commerce v1.1.2 Is it supposed to do that?

Let me know if you need anything else!

Thanks!

Gilmore


User avatar
Active Member

Posts

Joined
Thu Aug 12, 2010 7:33 am

Post by straightlight » Thu Apr 08, 2021 10:50 pm

Gilmore wrote:
Thu Apr 08, 2021 10:36 pm
I'm running OC v3.0.3.2 PHP v7.3.27

I had upgraded to the latest, but the PayPal Pay in 4 didn't agree with my layout and was confusing for my customers. I had instant complaints about it. So I went back to the previous one. Is there a way to disable the buttons that PayPal Pay in 4 places on my site since I don't need them on PayPal Commerce v1.2.0?

Also when I ran the installer, it still showed the previous version of PayPal Commerce v1.1.2 Is it supposed to do that?

Let me know if you need anything else!
Then, this means you're not using the v1.2.0 release of the extension. If you're not sure how to manage the extension, either contact the extension developer or create a new service request in the Commercial Support section of the forum, or contact me directly via PM, to get this done as a custom job.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ADD Creative » Fri Apr 09, 2021 12:38 am

Gilmore wrote:
Thu Apr 08, 2021 10:36 pm
I'm running OC v3.0.3.2 PHP v7.3.27

I had upgraded to the latest, but the PayPal Pay in 4 didn't agree with my layout and was confusing for my customers. I had instant complaints about it. So I went back to the previous one. Is there a way to disable the buttons that PayPal Pay in 4 places on my site since I don't need them on PayPal Commerce v1.2.0?

Also when I ran the installer, it still showed the previous version of PayPal Commerce v1.1.2 Is it supposed to do that?

Let me know if you need anything else!
In version 1.2.0 does not setting Pay Later Message to Disabled not switch off the messages?

This may also be related to this issue.
viewtopic.php?f=190&t=222974

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by Gilmore » Fri Apr 09, 2021 3:06 am

straightlight wrote:
Thu Apr 08, 2021 10:50 pm
Gilmore wrote:
Thu Apr 08, 2021 10:36 pm
I'm running OC v3.0.3.2 PHP v7.3.27

I had upgraded to the latest, but the PayPal Pay in 4 didn't agree with my layout and was confusing for my customers. I had instant complaints about it. So I went back to the previous one. Is there a way to disable the buttons that PayPal Pay in 4 places on my site since I don't need them on PayPal Commerce v1.2.0?

Also when I ran the installer, it still showed the previous version of PayPal Commerce v1.1.2 Is it supposed to do that?

Let me know if you need anything else!
Then, this means you're not using the v1.2.0 release of the extension. If you're not sure how to manage the extension, either contact the extension developer or create a new service request in the Commercial Support section of the forum, or contact me directly via PM, to get this done as a custom job.
LOL... too funny! I know how to manage Extensions. Only been using OC since OC1.x! I don't think you understand the problem. Let me try to explain it again...
PayPal Commerce Platform v1.2.0 now has PayPal Pay in 4 payments implemented.
I don't need PayPal Pay in 4 feature.
PayPal Commerce Platform v1.2.0 needs to have a place in the extension to turn off that feature.
I have contacted them and got no response as many others have not gotten a response about the Advance Card failing in the extension comment section.
I have now upgraded to PayPal Commerce Platform v1.1.5 and will see if that fixes it.
If I remove paypalcommercepatformoc3xv1.1.2.ocmod.zip from the Extension Installer, it breaks the payment system.
If the Extension was coded properly, then it should see the older version and remove it and not break it!
The PayPal Commerce Platform does not have any Change Logs to show us what was changed to fix what problems were in each version.

So one problem, Advance Card works sometimes and it fails sometimes and still shows the order complete while no payment for that order that failed showing up in PayPal.
Second problem, no way to turn off the Pay in 4 feature button in v1.2.0
Third problem, upgrading from v1.1.2 to v1.1.5 leaves paypalcommercepatformoc3xv1.1.2.ocmod.zip in the installer as well as paypalcommercepatformoc3xv1.1.5.ocmod.zip. Now if you know a way to remove paypalcommercepatformoc3xv1.1.2.ocmod.zip without breaking it, please tell us. If leaving paypalcommercepatformoc3xv1.1.2.ocmod.zip is fine, then not a problem. I'll leave it.

Thanks!

Gilmore


User avatar
Active Member

Posts

Joined
Thu Aug 12, 2010 7:33 am
Who is online

Users browsing this forum: No registered users and 6 guests