Post by baxterdmutt » Wed Apr 14, 2021 10:04 am

Hi all,
I'm always hesitant to bother folks and try to figure issues out on my own but I'm at a complete loss. I've installed a fresh version 3.0.3.7 as a git clone off of GitHub. I followed the instructions in the install text and went so far as to set the directory permissions to 777. The shopping pages seem to work but the Admin panel will not save any changes I make. One of 2 things will happen, after making a change (as an example changes the name of the store) (From the Dashboard->System->settings->general->store name) and clicking save, takes me back to the login screen and nothing gets saved. Changing other settings like those in localization and clicking save, nothing at all happens.
There is nothing in the logs to help.

I'm really looking forward to using this app because it looks great, but I need help getting past this issue please.
Roger

Newbie

Posts

Joined
Wed Apr 14, 2021 9:22 am

Post by straightlight » Wed Apr 14, 2021 10:52 pm

The storage folder must be located outside of your public_html folder manually and edit both config.php files' server paths accordingly. Folder permissions should never be set to 0777. Rather, they need to be set to CHMOD 0755 on a recursive mode. Files permission must not be changed.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 10 guests