Admin Customer Reset Password

Admin Customer Reset Password
The opencart admin allows you to update a customer's password, by firstly editing the customer and only then presenting you with a pair of password/confirm text boxes. When the changes are saved, the customer is not notified of the new password which defeats the purpose of the exercise. Additionally, the fact that the admin is able to choose the password makes it weak from a security perspective.

This extension is the perfect tool to use when, for example, you are migrating one of the competing open source platforms to opencart, or where, for security reasons, you need to reset all of your existing customers password.

This extension follows similar logic to how the "forgotten password" functionality normally works, but allows an admin to effectively reset the password for a customer. When this is done, the customer is also notified via email of the new password. This approach has the following benefits:
a) The password is randomly generated.
b) The email is nice and user-friendly and also includes a link to the login screen on the store that the customer is associated with, so it is store-aware.
c) The option is available directly on the admin customer list, so no need to go into the customer in order to reset the password.

It is also possible to do a bulk password reset by selecting the customers and clicking the "Bulk Password Reset" button

It's recommended to install VQMod Manager to enable or disable the extension.

An example of the email content is as follows:
************SNIPSNIPSNIPSNIPSNIPSNIPSNIP---------------------------------------------------------------------------------
Subject:
--------
MyStoreName (http://my_store_url/) - Customer Account Updated

Content:
--------
Your customer account with MyStoreName (http://my_store_url/) has been updated, and your password reset.

Your new password is:

9556ba7df9

Please follow this link to log in and update your account: http://my_store_url/index.php?route=account/login.

Regards
MyStoreName
************SNIPSNIPSNIPSNIPSNIPSNIPSNIP---------------------------------------------------------------------------------


This plugin is now certified to now work with version 1.5.x.x of Opencart and version 2.x.x.x of Opencart.

If you want the version that works with version 1.5.x.x of opencart, download version 1 of this plugin. If you want the version that is compatible with version 2, then download version 2 of this plugin.

Note that support has also been added for OCMOD as well as VQMOD now.




Buy
Price
$20.00

  • Developed by OpenCart Community
  • Documentation Included

Rating

Compatibility
1.5.0, 1.5.0.1, 1.5.0.2, 1.5.0.3, 1.5.0.4, 1.5.0.5, 1.5.1, 1.5.1.1, 1.5.1.2, 1.5.1.3, 1.5.2, 1.5.2.1, 1.5.3, 1.5.3.1, 1.5.4, 1.5.4.1, 1.5.5, 1.5.5.1, 1.5.6, 1.5.6.1, 1.5.6.2, 1.5.6.3, 1.5.6.4, 2.0.0.0, 2.0.1.0, 2.0.1.1, 2.0.2.0, 2.0.3.1, 2.1.0.1, 2.1.0.2, 2.0.0.0, 2.0.1.0, 2.0.1.1, 2.0.2.0, 2.0.3.1

Last Update
16 Aug 2016

Created
23 Jan 2014
33 Sales
27 Comments
panagos@gmail.com
panagos@gmail.com
Member since: 27 Oct 2012

View all extensions Get Support