Forced SSL Everywhere OC 1.x - 3.x

Forced SSL Everywhere OC 1.x - 3.x





Forced SSL Everywhere OC 1.x - 3.x



Important!
With the new security standard rolled out by Google in November 2017 it may kill your site ranking if your site contains insecure forms. On the other hand implementing SSL certification correctly could boost your search engine rankings considerably because Google uses both HTTPS and SSL as a ranking signal and a even a tiebreaker to decide which of the similar sites gets a higher spot in the search results.


New!
OCMOD version is available for download!


This extension forces the SSL mode for ALL existing links and media in OpenCart for both admin and front end sessions, protecting your site from hacker attacks.

What You Get

  • Forced SSL For All Links & Media

  • Higher Rank In Google
    Google has announced that going HTTPS will give you a minor ranking boost

  • More Trustworthy Site For Visitors
    With a nice green lock on the top left on all pages your site looks more trustworthy for the visitors.

  • Reclaimed Lost SEO Link Juice
    Solves the lost link juice issue by passing the link juice from http:// to https:// resources ensuring better ranking for your pages in search results. Also consolidates SEO juice on the main domain by redirecting index.php to the site root.

  • Resolved SEO Duplicate Content Issue
    Resolves the duplicate content issue in search engines caused by http:// and https:// resources being indexed separately and by multiple URLs pointing to the same home page.

  • Resolved Mixed/Insecure Content Issue
    Resolves the problem with mixed/insecure content when HTTPS pages include resources through HTTP connection.

  • Solves missing icons and fonts problem
    Resolves the problem with fonts or icons not being displayed when sites are accessed with or without www perfix.

  • Admin And Users Account Protection
    Having even one page not encrypted with SSL makes your site vulnerable for man-in-the-middle attacks when hackers can sniff out a cookie passed over non secure connection very easily and take over an account completely (admin or front end user account).

Key features:

  • Works with any OC theme and extension

  • OC v3.x ready while working on OC v1.5.x
    The single xml file supports both OC v1.5.x and OC v3.0. If you decide to upgrade to OC v3.x it won't require you to install a new file, the same file will work fine on any version of OC.

  • Easy install
    Simply put force-ssl.xml file into the vqmod/xml folder or install with vqmod.
    The module takes effect immediately after being uploaded. No need to activate it in the admin settings anymore.
    If not working make sure "Use SSL" setting is set to "Yes" in Admin -> System -> Settings -> Your site and click "Save" anyway.

  • No changes in the .htaccess file.
    The redirect is done during the earliest system start-up to reduce unnecessary server load.

  • SSL Forced 301 Redirect
    Built-in SSL Forced 301 Redirect from http:// to https://
    Certain URLs can be added to the exception rules so that they are never forced to https.

  • Automatic 301 redirect to www or non-www version
    Redirects to the original version of the site defined in the config files (or in the multi store configuration) to avoid cross-domain problems.

  • SSL Reversed Proxy & Load Balanced SSL Proxy support
    Automatically detects and fixes the problem with SSL Reversed Proxy & Load Balanced SSL Proxy when all https pages are displayed without any css formatting or with security warnings and errors.

  • Restores the original IP of the visitor for CloudFlare users

  • Added a fix for Paladin Redirect Manager unable to redirect https URLs

  • Added a fix for Redirect Manager by Clear Thinking unable to redirect old http:// URLs

  • Add-on to 301 redirect index.php to the site root.

  • Fixes invalid SSL related settings in the config files.

  • Fixed order related API problems in multistore configuration for OC 2.x.

  • Fixed some problems with SSL enabled for some stores only in multi-store configuration.

  • Fixed a bug in OC 2.2.0.0 making order details not working in https and other SSL related problems

  • Multi-store compatible
    Forces SSL only for the stores you enable SSL on.


Requirements:

- Opencart 1.x - 3.x
- vQmod
- a valid SSL certificate


Guarantee

Attention! In case it is not working for you please provide me with ftp + admin access using the "Request Support" button above and I will fix it or refund the money if you choose so. Or simply send an email to support [at] sdv [dot] com [dot] ua or send me a private message here with access details

What customers say about Forced SSL Everywhere OC 1.x - 3.x

slingeraap
Super! Great and fast support!
~slingeraap
stojkovikj
Works great! Support is also very friendly and responsive. Highly recommend it!
~stojkovikj
furnica10
fast support!
~furnica10




Buy
Price
$25.00

  • Developed by OpenCart Community
  • 12 Months Free Support
  • Documentation Included

Rating

Compatibility
1.4.7, 1.4.8, 1.4.8b, 1.4.9, 1.4.9.1, 1.4.9.2, 1.4.9.3, 1.4.9.4, 1.4.9.5, 1.5.0, 1.5.0.1, 1.5.0.2, 1.5.0.3, 1.5.0.4, 1.5.0.5, 1.5.1, 1.5.1.1, 1.4.9.6, 1.5.1.2, 1.5.1.3, 1.5.2, 1.5.2.1, 1.5.3, 1.5.3.1, 1.5.4, 1.5.4.1, 1.5.5, 1.5.5.1, 1.5.6, 1.5.6.1, 1.5.6.2, 1.5.6.3, 1.5.6.4, 2.0.0.0, 2.0.1.0, 2.0.1.1, 2.0.2.0, 2.0.3.1, 2.1.0.1, 2.1.0.2, 2.2.0.0, 2.3.0.0, 2.3.0.1, 2.3.0.2, 3.0.0.0, 3.0.1.1, 3.0.1.2, 3.0.2.0, 3.0.3.0b, 2.0.0.0, 2.0.1.0, 2.0.1.1, 2.0.2.0, 2.0.3.1, 2.1.0.1, 2.1.0.2, 2.2.0.0, 2.3.0.0, 2.3.0.1, 2.3.0.2, 1.4.7, 1.4.8, 1.4.8b, 1.4.9, 1.4.9.1, 1.4.9.2, 1.4.9.3, 1.4.9.4, 1.4.9.5, 1.5.0, 1.5.0.1, 1.5.0.2, 1.5.0.3, 1.5.0.4, 1.5.0.5, 1.5.1, 1.5.1.1, 1.4.9.6, 1.5.1.2, 1.5.1.3, 1.5.2, 1.5.2.1, 1.5.3, 1.5.3.1, 1.5.4, 1.5.4.1, 1.5.5, 1.5.5.1, 1.5.6, 1.5.6.1, 1.5.6.2, 1.5.6.3, 1.5.6.4, 2.0.0.0, 2.0.1.0, 2.0.1.1, 2.0.2.0, 2.0.3.1, 2.1.0.1, 2.1.0.2, 2.2.0.0, 2.3.0.0, 2.3.0.1, 2.3.0.2, 2.0.0.0, 2.0.1.0, 2.0.1.1, 2.0.2.0, 2.0.3.1, 2.1.0.1, 2.1.0.2, 2.2.0.0, 2.3.0.0, 2.3.0.1, 2.3.0.2, 1.5.3, 1.5.3.1, 1.5.4, 1.5.4.1, 1.5.5, 1.5.5.1, 1.5.6, 1.5.6.1, 1.5.6.2, 1.5.6.3, 1.5.6.4, 2.0.0.0, 2.0.1.0, 2.0.1.1, 2.0.2.0, 2.0.3.1, 2.1.0.1, 2.1.0.2, 2.2.0.0, 2.3.0.0, 2.3.0.1, 2.3.0.2

Last Update
9 Dec 2017

Created
1 May 2015
588 Sales
231 Comments
deepvision
deepvision
Member since: 18 Aug 2014

View all extensions Get Support