SagePay V3 iFrame Checkout with Telephone Payments

SagePay V3 iFrame Checkout with Telephone Payments






Test card details for test transactions:

Card Number: 4929 0000 0000 6

CV2 Value: 123

3D Secure: password (case sensitive)

SagePay V3 iFrame Checkout, Admin Telephone Payments

Overview:

The extension allows to accept payments from your customers on both backend and frontend sides by integrating Sage Pay payments via iFrame Protocol:
  • a manual/telephone payment from admin for already placed orders;
  • on the Account Order Info page frontend;
  • during checkout process.


Key Features:

Server iFrame Integration Protocol support
Customers stay on your site and a Sage Pay checkout page will appear on your site through an iFrame.

Checkout Process Integration
Accept payments from your customers on the front end of your store during checkout process. Just enable "SagePay Telephone V3" extension to be able to accept payments on the front end.

Backend Telephone Payments
Accept payments over phone from admin side for already placed pending orders. The extension adds the "Make Payment" button to the Order Info page in Admin.

Frontend Account Order Integration
Customers can pay already placed orders from from the Order History section of their Account. The extension adds the "Make Payment" button to the Account Order Info page.

Configurable popup/inline checkout mode

Configurable Minimal/Full profile option
"Minimal"</i> profile displays the simplified payment pages which have only one step and minimal formatting.
[i]"Full"
profile renders the normal card selection screen.

Responsive Layout Support
Supports SagePay Responsive Pages

Easy install
Just upload the content of "upload" folder and install the extension in Extension -> Payments section of Admin Panel. No core files modified.

Built-in support for OC v1.5.x - v2.x
The extension automatically detects OC version and works on any OC v1.5.x - OC v2.x. If you decide to upgrade to OC v2.x it won't require you to uninstall existing module and install a new one, the same module will work fine on any version of OC.

Multi-store compatible

If you require a feature which is not yet supported in our extension please contact us via support [at] sdv [dot] com [dot] ua email we will do our best to add it.

Supported Open Cart Versions:
1.5.x - 2.x

If your version is not supported contact us at support [at] sdv [dot] com [dot] ua and we will make it work or full refund your money.

Requirements:

- Opencart v1.5.x/v2.0.x
- vQmod

Guarantee

Attention! In case it is not working for you please provide me with ftp + admin access using the "Request Support" button above and I will fix it or refund the money if you choose so. Or simply send an email to support [at] sdv [dot] com [dot] ua or send me a private message here with access details




Buy
Price
$25.00

  • Developed by OpenCart Community
  • 12 Months Free Support
  • Documentation Included

Rating

Compatibility
1.5.4, 1.5.4.1, 1.5.5, 1.5.5.1, 1.5.6, 1.5.6.1, 1.5.6.2, 1.5.6.3, 1.5.6.4, 2.0.0.0, 2.0.1.0, 2.0.1.1, 2.0.2.0, 2.0.3.1, 2.1.0.1, 2.1.0.2, 2.2.0.0, 2.3.0.0, 2.3.0.1, 2.3.0.2

Last Update
19 Oct 2017

Created
5 May 2015
57 Sales
49 Comments
deepvision
deepvision
Member since: 18 Aug 2014

View all extensions Get Support