TLT Braintree Payments with 3DS 2.0, PayPal and Google Pay

TLT Braintree Payments with 3DS 2.0, PayPal and Google Pay
TLT Braintree Payment Gateway for Opencart 2.x

3D Secure 1.0/2.0 support

TLT Braintree ver. 4.1 uses Braintree Javascript v.3 SDK and supports both 1.0 and 2.0 versions of the 3D Secure. This version works with Opencart 2.0, 2.1, 2.3 only. Opencart 2.2 is not supported.

Google Pay and PayPal

Google Pay and PayPal support works with Opencart 2.0, 2.1, 2.3 only. Opencart 2.2 is not supported.

Braintree is a full-stack payments platform that makes it easy to accept payments on your website.

TLT Braintree Payment Gateway for Opencart is a free, multi currency, easy to install and use solution for accepting cards, Bitcoin, Paypal or Venmo payments in Opencart.

TLT Braintree Payment Gateway uses BraintreeJavascript 3.0 SDL, which is a complete, readymade payment UI for any website.

More information about Braintree you can get here: https://www.braintreepayments.com/faq

For support please contact me by email, which you can find in Readme.txt

My extensions for Opencart

Important
If you get connection error like 'Cannot connect to the bank. Please try again later or use PayPal.' switch the debug mode to on, try to pay and check Opencart error log.

Message like 'Debug Info: #0 /path_to_opencart/system/braintree/lib/Braintree/Http.php(47): Braintree\Util::throwStatusCodeException(403)' means, that the Merchant Account ID value is not valid.

Open the Braintree settings and enter value from your Braintree credentials. Merchant account ID and Merchant ID are two different values with distinct purposes.

More information about it you can get from Braintree support article.
https://articles.braintreepayments.com/control-panel/important-gateway-credentials#merchant-account-id-vs.-merchant-id

Please also note, that Braintree credentials for sandbox and production are different. Don't mismatch it!

Journal2 theme
If you use one page checkout from the Journal2 theme you should open checkout.tpl of the Journal2 theme, find
var $btn = $('#payment-confirm-button input[type="button"], #payment-confirm-button input[type="submit"], #payment-confirm-button .pull-right a, #payment-confirm-button .right a, #payment-confirm-button a.button, #button-confirm, #button-pay, #payment-confirm-button.payment-iyzico_checkout_installment .submitButton, #stripe-confirm').first();
and add #submitButton to the list.

Opencart 2.3.x support

If you have Opencart 2.3.x you should download TLT Braintree X.X-OC2.3 version. This version works with OC 2.3.x only!

Opencart 2.2.x support

If you have Opencart 2.2.x you should download TLT Braintree 3.1 version. This version works with OC 2.2.x only!

Please note that Opencart 2.2.0 has some critical bugs so I don't recommend to use it for production.

Nevertheless Braintree library included in compiled versions of OC 2.2.x and 2.3.x you steel need to install the library how is described in readme.txt.

TLS 1.2 support

If your server isn't configured to use TLS 1.2 encryption by default you can enable TLS 1.2 in TLT Braintree settings. You need Braintree ver. 3.21.0 or more. Please note that in this case another parts of your shop can use less secure encryption, so is better to configure your server properly.




Download
  • Developed by OpenCart Community
  • Documentation Included

Rating

Compatibility
2.0.0.0, 2.0.1.0, 2.0.1.1, 2.0.2.0, 2.0.3.1, 2.1.0.1, 2.1.0.2, 2.3.0.0, 2.3.0.1, 2.3.0.2, 2.2.0.0

Last Update
28 Oct 2020

Created
16 Dec 2015
953 Downloads
84 Comments
timber
timber
Member since: 23 Sep 2015

View all extensions Get Support